Results 1 to 2 of 2

Thread: Wrong EDID, how to set correct resolution

  1. #1
    Join Date
    Dec 2008
    Location
    Syros, Greece
    Posts
    29

    Default Wrong EDID, how to set correct resolution

    I have a very difficult time to set the correct resolution of my monitor with fglrx.

    My monitor is a 22" LG W2234S that has 1680x1050 as optimal resolution. Catalyst driver always sets my monitor to 1600x1200 that it is not correct.

    Until Catalyst 9.11 i was able to force the correct resolution by executing

    Code:
    aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
    and add

    Code:
    Modes "1680x1050"
    in SubSection "Display", Section "Screen" in my xorg.conf.

    With Catalyst 9.12 if i try this i'm getting a blank screen although X is loading and i can log on blindly.

    It is a major headache not to be able to set the correct resolution.

    I have tried to pass custom modelines to xorg.conf but fglrx seems to ignore them.

    How can i set the correct resolution for my monitor.

    Please ATI take a look on this baby issues of the driver. I think that my monitor reports (or fglrx understands) wrong EDID values, but there must be a way to force the correct resolution.

    Thanks.
    Last edited by baskin; 12-18-2009 at 12:08 PM.

  2. #2
    Join Date
    Dec 2008
    Location
    Syros, Greece
    Posts
    29

    Default

    Ok i did it.

    After struggling with xrandr to add custom modelines and amdcccle to configure the right geometry for the optimal resolution, it seems to working now.

    I'm not sure i can blame fglrx or my monitor but i want to say that fglrx should respect the xorg.conf values, because with open source drivers a single line in my xorg.conf is the only thing neeeded.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •