Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 1920x1200 on X1300 - driver problem?

  1. #1
    Join Date
    Dec 2009
    Posts
    7

    Default 1920x1200 on X1300 - driver problem?

    Hello ^_^

    I am a big fan of ATi graphics cards, so I have a lot of them in many computers. I have stumbled upon a weird, uhm, feature of the Catalyst Control Center. I have a Samsung SyncMaster 245B monitor; its native resolution is 1920x1200, but Catalyst says it's only 1600x1200, so if I enable the native 1920x1200 - it only shows the upper-left part of the screen. And, surprisingly enough, there is no button to disable EDID - as it was on Windows! I am running Debian Lenny amd64 with an X1300, so it's Catalyst 9.3 we're talking about. I remember I've had exactly the same problem on Windows also, and there was the "Disable EDID" button, but it just did not work! When I checked it, it just self-unchecked when I pressed Apply or restarted Catalyst (that was a long time ago, I don't remember exactly). I also don't remember whether I was able to do something (like another version of the driver) or even what card and what version of Catalyst did I use, but I did research this feature thoroughly enough and will be happy to provide any information needed.

    The system acknowledges the 1920x1200 mode, it's even possible to set it, but the problem is that it only shows a part of the screen if this mode is set. This might be the problem of the monitor, not the graphics card, but there must be a way to disable looking at EDID anyway, The open-source driver works well. It is also possible to start X with the 1920x1200 resolution and it is displayed properly, but when I go to another console (Ctrl-Alt-F1) and then go back to X, if turns out like this. (On the open-source drivers, it works fine.) So the problem only occures if I try to set the 1920x1200 mode under X (I even tried xrandr --size 1920x1200 - it leads to the same result).

    I tried the driver available for download from the ati.amd.com site (for X1300 - it's Catalyst 9.3); I also tried the one in the Debian repository, which goes both for DirectX 9 and DirectX 10 cards, and the problem persists; I also tried the 9.12 version of the driver from ati.amd.com, but it failed to install - "no supported cards found". I tried the one from the repository (I don't know how to see its version) on another machine under Debian Lenny x86 and Radeon 9600 AGP, and it was working well; the driver is the same for x86 and x64 systems, so this must be the problem of X1300.

    Searching the Internet for the whole night did not help me (maybe I am not good enough at searching though...), but at least helped to figure out this much information about the problem. I wonder if there is a solution for this...

  2. #2
    Join Date
    Aug 2007
    Posts
    6,627

    Default

    Tweak your config file. Check /var/log/Xorg.0.log and optimize it then. Most likely you will need

    Section "Monitor"
    Identifier "Configured Monitor"
    HorizSync 30-75
    VertRefresh 50-75
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1920x1200"
    EndSubSection
    EndSection

    If it does not work check out Kanotix Excalibur - http://kanotix.com - dl links on the left side, has got newer ati oss driver.

  3. #3
    Join Date
    Dec 2009
    Posts
    7

    Default

    Thank you, I will try that Excalibur thing. My xorg.conf is already tuned with those options:

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Monitor Model"
    HorizSync 50.0 - 80.0
    VertRefresh 50.0 - 200.0 # 1920x1200 uses 193 VertRefr
    ModeLine "1920x1200_60.00" 193.2 1920 2048 2256 2592 1200 1201 1204 1242 -hsync +vsync
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Card0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Virtual 1920 1200 # trying to blame xrandr
    Depth 24
    Modes "1920x1200"
    EndSubSection
    EndSection

  4. #4
    Join Date
    Dec 2009
    Posts
    7

    Default

    Here's something from my Xorg.0.log. I did not notice this earlier, but there are "default" modes and modes marked with a "*" . There was only one marked mode - 1920x1200 - but when I deleted this mode from xorg.conf, mode marked modes appeared. Hmm... So, 1920x1080 is the "default" one?.. Let's try it... Nope, this one also gets halved... And 1600x1200, which is "marked", works well... I guess the driver has a special love towards the good old non-widescreen modes...

    I have also noticed that when I'm using the fglrx driver, the X server does not die until I kill it - and not just kill -TERM, but only kill -KILL !!.. (This does not apply to logging out normally - only to the situation when I /etc/init.d/gdm stop or restart)

  5. #5
    Join Date
    Aug 2007
    Posts
    6,627

    Default

    Usually fglrx ignores modelines (i would just remove it), btw. your modeline is WRONG for single link dvi:

    # 1920x1200 59.95 Hz (CVT 2.30MA-R) hsync: 74.04 kHz; pclk: 154.00 MHz
    Modeline "1920x1200R" 154.00 1920 1968 2000 2080 1200 1203 1209 1235 +hsync -vsync

    this would be with reduced blanking, and the mode name is then "1920x1200R" not "1920x1200" in the Modes section. You need to know of course if your monitor is 16:10 or 16:9!

  6. #6
    Join Date
    Dec 2009
    Posts
    7

    Default

    My monitor is connected via a VGA cable. I used the modeline I got with gtf 1920 1200 60 -x . So, the R option means DVI-specific refresh mode with reduced blanking?.. BTW, my monitor is 16:10 - a 16:9's resolution is 1920x1080.

  7. #7
    Join Date
    Dec 2009
    Posts
    7

    Default

    I downloaded Kanotix, but I realized that its images are DVD-size, and I have an old CD-only drive on that computer ("why would a server need a DVD drive if it's only used for installing the system", I thought). I have tried it on another computer that has even more problematic and new Radeon HD4350, and it worked with "radeon" driver (no DRI, as glxtest said). The version of this driver was the same as the one in the Debian repository. Weird, it does not work with the same driver in my system... "No devices detected" for "radeon"... I will try to connect a DVD drive via USB and try. Oh, I love Linux!.. So very perverted things came true with Linux! ^_^

  8. #8
    Join Date
    Dec 2009
    Posts
    7

    Default

    I wonder if there is a way to uninstall the driver package from the website?.. apt-get remove fglrx-* says nothing is installed...

  9. #9
    Join Date
    Aug 2007
    Posts
    6,627

    Default

    You can be sure that the ati driver is much newer:

    ii xserver-xorg-video-ati 1:6.12.4+git20091117.51266161-0kanotix2 X.Org X server -- ATI display driver wrapper

    Also after hd install you could even install a .28 kernel (!28 hint in the chat) und run the install-fglrx-debian.sh script after booting this kernel. What would be of course also possible with plain Lenny.

  10. #10
    Join Date
    Dec 2009
    Posts
    7

    Default

    Oops. I already realized I was looking at the version in the Debian repository; now that I've removed it from sources, I see it's newer.

    Anyway, I need fglrx because VMware does not work with the "radeon" driver (I guess it uses some fglrx-specific features - if I run it on a computer where 3D works, VMware still says "there is no supported 3D"). My problem is to make fglrx work; I can use either a X1300 or a HD4350, but it has to work well in 1920x1200 with fglrx. So the question is, why does Catalyst not work well with 1920x1200?..

    I changed the graphic card to HD4350. It does now work well with fglrx, but the reason I removed it was that I suspected it to be the reason for my sudden system halts. Well, it's still not clear why does X1300 not like 1920x1200, it's older and therefore supposedly better supported... I hope 4350 + glitchy fglrx was not the true reason for the halts...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •