Results 1 to 2 of 2

Thread: Display settings keep resetting

  1. #1
    Join Date
    Dec 2009
    Posts
    2

    Default Display settings keep resetting

    Hi there,
    I'm running Debian Lenny, kernel 2.6.26-2 and using the fglrx driver (and tools) version 1:8-12-4.

    I'm running an LCD monitor through DVI which should be running at 1680x1050 and a full HD TV which should be running at 1980x1050 but even though i've forced these settings they revert back to incorrect settings.

    At the moment, with xinerama on or off, the following xorg.conf configures the LCD monitor (identified as screen 1) to 1980x1080 and the TV to 1280x1024.

    lspci and aticonfig --list-adapters both show 6:0:0 to be the only adapter which was the only thing i could think of that would cause an issue.

    Any ideas?
    Xorg.conf follows, thanks in advance for your thoughts and help.

    Section "ServerLayout"
    Identifier "Simple Layout"
    Screen 0 "Screen 1" 0 0
    Screen "Screen 2" RightOf "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/misc"
    FontPath "/usr/share/fonts/75dpi"
    FontPath "/usr/share/fonts/100dpi"
    FontPath "/usr/share/fonts/Type1"
    EndSection

    Section "Module"
    Load "dbe" # Double buffer extension
    SubSection "extmod"
    Option "omit" "xfree86-dga" # don't initialise the DGA extension
    EndSubSection
    Load "freetype"
    Load "glx"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "off"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol Auto" # Auto detect
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    Section "Monitor"
    Identifier "Monitor1"
    HorizSync 31.5 - 64.3
    VertRefresh 50.0 - 100.0
    Option "DPMS" "true"
    EndSection

    Section "Monitor"
    Identifier "Monitor2"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "Radeon9700-1"
    Driver "fglrx"
    Option "DPMS"
    #VideoRam 65536
    Option "xK�k" "�q�w�m"
    BusID "PCI:6:0:0"
    EndSection

    Section "Device"
    Identifier "Radeon9700-2"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "Screen 1"
    Device "Radeon9700-1"
    Monitor "Monitor1"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1680x1050"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "Screen 2"
    Device "Radeon9700-2"
    Monitor "Monitor2"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1920x1080"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

  2. #2
    Join Date
    Dec 2009
    Posts
    2

    Default

    Now using this, which is a bit cleaner (stripped it out and then used aticonfig to repopulate)
    This sets up screen one properly but screen two is 1680x1050 instead of 1920x1080

    Section "ServerLayout"
    Identifier "Simple Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    Screen "aticonfig-Screen[0]-1" RightOf "aticonfig-Screen[0]-0"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
    EndSection

    Section "Files"
    FontPath "/usr/share/fonts/misc"
    FontPath "/usr/share/fonts/75dpi"
    FontPath "/usr/share/fonts/100dpi"
    FontPath "/usr/share/fonts/Type1"
    EndSection

    Section "Module"
    Load "dbe" # Double buffer extension
    SubSection "extmod"
    Option "omit" "xfree86-dga" # don't initialise the DGA extension
    EndSubSection
    Load "freetype"
    Load "glx"
    Load "dri"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "AutoRepeat" "500 30"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol Auto" # Auto detect
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-1"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    Screen 0
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-1"
    Driver "fglrx"
    BusID "PCI:6:0:0"
    Screen 1
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1680x1050"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-1"
    Device "aticonfig-Device[0]-1"
    Monitor "aticonfig-Monitor[0]-1"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1920x1080"
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •