Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: EDID and KMS

Hybrid View

  1. #1
    Join Date
    Dec 2009
    Location
    Mountain View, CA, USA
    Posts
    5

    Default EDID and KMS

    I've been using the latest Git-sourced versions of radeon, mesa, and libdrm and they've largely been working great, but X fails to detect all video resolutions my monitor is capable of, including my preferred resolution (1280x960). This was irritating until I found the "IgnoreEDID" option in xorg.conf.

    However, I just recompiled my kernel with the "Enable modesetting on radeon by default" option set. Works fine (well, sometimes) except I'm stuck with the same limited number of resolutions again. "IgnoreEDID" is itself completely ignored.

    Any ideas what the explanation (and resolution, hopefully) is?

  2. #2
    Join Date
    Dec 2007
    Posts
    2,326

    Default

    The driver only exposes modes that are in the EDID provided by the monitor. Arbitrary modes (like 1280x960) have to be added manually.

  3. #3
    Join Date
    Dec 2009
    Location
    Mountain View, CA, USA
    Posts
    5

    Default

    Does that mean editing a custom EDID file? Are there any guides for that? (I haven't found any)

  4. #4
    Join Date
    Dec 2007
    Posts
    2,326

    Default

    You don't need a custom EDID, you just have to add modelines to your xorg config for the modes you want to add. THis page is a good reference:
    http://wiki.debian.org/XStrikeForce/HowToRandR12

  5. #5
    Join Date
    Dec 2009
    Location
    Mountain View, CA, USA
    Posts
    5

    Default

    Fantastic. Thanks!

  6. #6
    Join Date
    Dec 2009
    Location
    Mountain View, CA, USA
    Posts
    5

    Default

    So it works, but there's one thing that has me worried. I use a CRT monitor. Although I used 'gtf' to generate an entry using the same horizontal resolution, vertical resolution and refresh rate that're detected with IgnoreEDID (as well as by Windows), *something* is different, since I have to fiddle with the monitor controls again (size, position, pincushion, etc.). Do I have any reason so worry that this indicates that it's set wrong and therefore could harm my monitor?

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    It's not likely to harm your monitor, but if you wanted to be sure you could probably look at the logs when running UMS and find out the exact timing entry (presumably one of the X server defaults) that you were using before, then tweak your new settings to match.

  8. #8
    Join Date
    Dec 2009
    Location
    Mountain View, CA, USA
    Posts
    5

    Default

    What part of the log should I be looking at? I don't see anything that obviously has to do with timing.

  9. #9
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    IIRC near the front of the log there's a dump of all the available modes with timing info (each mode has a name string plus a list of numbers), then later on there's a couple of cryptic messages telling you which of those modes was selected (via name string).

  10. #10
    Join Date
    Dec 2007
    Posts
    2,326

    Default

    windows may use cvt to generate the mode. You might try a cvt made rather than gtf. If the mode sync ranges and clock are within the limits of the monitor it should be fine. the adjustments you need to make to your monitor are due to slight differences in the mode timing, probably due to gtf vs cvt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •