Quote Originally Posted by bridgman View Post
For 3xx-5xx there was already a Gallium3D driver and developer focus had already shifted to the Gallium3D driver. Since the Gallium3D driver for 3xx-5xx already *had* GLSL and GL2.1 enabled [...]
Are you sure about this?
It's been a few weeks since I tried r300g but iirc it didn't have GLSL/GL2.1 yet. Afaik it's supposedly being implemented by nhaehnle in his r300g-glsl branch, but that has not seen any commits since more than two months so I didn't even bother giving it a try.
But I'll give r300g a try again tomorrow.