Results 1 to 8 of 8

Thread: Spring RTS / Complete Annihilation

  1. #1
    Join Date
    Jan 2008
    Posts
    68

    Default Spring RTS / Complete Annihilation

    Hi I start this thread to improve the workings of this GPL mod and GPL engine on the open radeon driver.

    On r300 it worked ok, be it slow.
    Now I upgraded to an r600 powered chip (RV730), And it has texture issues, white terrain, half the units are white. The rest works more or less flawless, and the performance is very good.
    It's most likely a s3tc issue.

    So if anyone has tips, please respond.

  2. #2
    Join Date
    Jan 2008
    Posts
    68

  3. #3
    Join Date
    Jul 2008
    Location
    Berlin, Germany
    Posts
    822

    Default

    Spring with Balanced Annihilation mod will not even start here (rs780, mesa from git) unless I disable shadows and advanced unit shading in ~/.springrc (bug 25024).
    But apart from that it works with some graphical glitches (eg. ground texture is white as you mentioned).

  4. #4
    Join Date
    Jun 2008
    Posts
    19

    Default

    For S3TC, it sould be OK with 2.6.33-rc1, Ok on 2.6.32 with the patch mentioned here :

    http://bugs.freedesktop.org/show_bug.cgi?id=24593

    With this Spring is OK on my R500

  5. #5
    Join Date
    Aug 2009
    Posts
    122

    Default

    Quote Originally Posted by rem5 View Post
    For S3TC, it sould be OK with 2.6.33-rc1, Ok on 2.6.32 with the patch mentioned here :

    http://bugs.freedesktop.org/show_bug.cgi?id=24593

    With this Spring is OK on my R500
    is this fix only for R300-R500 family ?

  6. #6
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,072

    Default

    R100-R500 according to the commit

  7. #7
    Join Date
    Jan 2008
    Posts
    68

    Default

    r6/700 is not fixed no with latest git of kernel drm and ddx/mesa/libdrm, it lacks the whole s3tc part in the driver, no hooks to libdxtn either.

    Another small issue with the present driver is it only supports 256MB videoram. So I'm wasting 750 of my 1G at the moment ;p

  8. #8
    Join Date
    Jan 2008
    Posts
    68

    Default

    please please please hack s3tc support in mesa for R600

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •