Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Wine Black-Skin-bug in beta-Catalyst 8.660/9.10

  1. #1
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default Wine Black-Skin-bug in beta-Catalyst 8.660/9.10

    Wine Black-Skin-bug in beta-Catalyst 8.660/9.10

    9.10beta on wine 1.1.31 (1.1.30 same problem)


    Catalyst is broken again...

    9-8


    9-7


    9-5/9-6 has the same blackskinbug.


    I hope amd fix the Bug in the Stable 9.10 catalyst.

  2. #2
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    so ok now i test on fglrx 8.66.2 and wine 1.1.32



    Same problem but i can now see the eye! WOW

    fixme:d3dx3DXGetImageInfoFromFileInMemory stub
    fixme:d3d:state_vertexblend_w Vertex blending enabled, but not supported by
    hardware
    fixme:d3d:state_zfunc D3DCMP_NOTEQUAL and D3DCMP_EQUAL do not work correctly yet
    fixme:d3dx3DXGetImageInfoFromFileInMemory stub
    Last edited by Qaridarium; 10-28-2009 at 10:02 AM.

  3. #3
    Join Date
    Mar 2009
    Posts
    214

    Default

    You know these sorts of bugs are hard to tell if they're a WINE bug or a catalyst bug. Have you filed a bug report at winehq? or searched for a similar bug?

    e.g. (Ubuntu 9.04 x86-64 P8600 4GB mobility 4850)
    wine 1.1.31 + cat 9.10 GW seems to work perfectly

    wine 1.1.32 + cat 9.10 GW char selection screen garbled, flashing triangles all over the game play screen, X3 Reunion all sorts of weird distorted textures(think that this is the GW char sel screen problem) in gameplay, scrambled game menu, etc.

    In the above cases I'm at leats partially inclined to blame wine...
    Sager NP8250-S Core i7-4800MQ/780m/32GB/128GB SSD/750GB Scorpio Black/1TB WD Blue(7mm) (win7 x64 pro)
    Acer Chromebook C720(i3-4005U/4GB) 128GB SSD(stable/crouton xfce)
    DIY ASUS P9X79/i7-3930k/64GB/multiple multiple terabyte HDDs(mostly WD 10k)/780 Ti SC (win7 x64 pro/Ubuntu 14.10)
    DIY ASROCK 990FX Extreme9/FX-9590/32GB/multiple multi-TB hdds/R9 280X

  4. #4
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by cutterjohn View Post
    You know these sorts of bugs are hard to tell if they're a WINE bug or a catalyst bug. Have you filed a bug report at winehq? or searched for a similar bug?

    e.g. (Ubuntu 9.04 x86-64 P8600 4GB mobility 4850)
    wine 1.1.31 + cat 9.10 GW seems to work perfectly

    wine 1.1.32 + cat 9.10 GW char selection screen garbled, flashing triangles all over the game play screen, X3 Reunion all sorts of weird distorted textures(think that this is the GW char sel screen problem) in gameplay, scrambled game menu, etc.

    In the above cases I'm at leats partially inclined to blame wine...


    "e.g. (Ubuntu 9.04 x86-64 P8600 4GB mobility 4850)
    wine 1.1.31 + cat 9.10 GW seems to work perfectly"

    on Oblivion or other games?? ?


    "wine 1.1.32 + cat 9.10 GW char selection screen garbled, flashing triangles all over the game play screen, X3 Reunion all sorts of weird distorted textures(think that this is the GW char sel screen problem) in gameplay, scrambled game menu, etc."

    realy.. i have the same bug in wine 1.1.30 and 1.1.31 and 1.1.32

    you have definitely an different problem to me...

    my bug-report is only for Oblivion.

    and yes i filled a bugreport at Codewavers side per crossover linux pro support ticket level 2

  5. #5
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    now i test the 9.11 and the blackskin bug is there to...

    blackskinbug... in the super nice catalyst 9.11 .......

  6. #6
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    Install Windows 7 and play there

  7. #7
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by RealNC View Post
    Install Windows 7 and play there
    if AMD pay me a windows7 version ??? so i will burn the amd windows7 lenience..

  8. #8
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    That's not an fglrx bug, you need a native d3dx9_xx dll, which can be seen in the d3dx fixmes.
    We haven't implemented anything but copying argb surfaces in D3DX, yet... The game most likely either uses some sort of filtering and/or some other texture format, which is not supported atm.

    EDIT: Just seeing that the affected function is actually D3DXGetImageInfoFromFileInMemory and not D3DXLoadSurfaceFromMemory; the former one isn't implemented at all, yet :/
    Last edited by NeoBrain; 11-13-2009 at 08:24 AM.

  9. #9
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default catalyst 9.12hotfix+wine1.1.35

    now i'm testing catalyst 9.12hotfix+wine1.1.35 and its still bugy!
    black-skin-bug already in the driver/wine

    fixme:d3dx3DXGetImageInfoFromFileInMemory stub
    fixme:d3d:state_vertexblend_w Vertex blending enabled, but not supported by hardware
    fixme:d3d:state_zfunc D3DCMP_NOTEQUAL and D3DCMP_EQUAL do not work correctly yet
    fixme:d3dx3DXGetImageInfoFromFileInMemory stub


  10. #10
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Quote Originally Posted by Qaridarium View Post
    now i'm testing catalyst 9.12hotfix+wine1.1.35 and its still bugy!
    black-skin-bug already in the driver/wine

    fixme:d3dx3DXGetImageInfoFromFileInMemory stub
    fixme:d3d:state_vertexblend_w Vertex blending enabled, but not supported by hardware
    fixme:d3d:state_zfunc D3DCMP_NOTEQUAL and D3DCMP_EQUAL do not work correctly yet
    fixme:d3dx3DXGetImageInfoFromFileInMemory stub
    and it won't work until either D3DXGetImageInfoFromFileInMemory is implemented or you use a native d3dx9_36 dll...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •