Results 1 to 2 of 2

Thread: Testing r100 with 2.6.32.2 kernel and F12 userspace

Threaded View

  1. #1
    Join Date
    Jul 2007
    Posts
    429

    Default Testing r100 with 2.6.32.2 kernel and F12 userspace

    KMS correctly initialises DVI-0 to its native 1280x1024 resolution. However, compiz fails to run:

    Code:
    [drm:r100_cs_track_texture_check] *ERROR* Texture of unit 0 needs 250880 bytes but is 4096
    [drm:r100_cs_track_texture_print] *ERROR* pitch                      5120
    [drm:r100_cs_track_texture_print] *ERROR* use_pitch                  1
    [drm:r100_cs_track_texture_print] *ERROR* width                      1280
    [drm:r100_cs_track_texture_print] *ERROR* width_11                   2048
    [drm:r100_cs_track_texture_print] *ERROR* height                     49
    [drm:r100_cs_track_texture_print] *ERROR* height_11                  2048
    [drm:r100_cs_track_texture_print] *ERROR* num levels                 0
    [drm:r100_cs_track_texture_print] *ERROR* depth                      0
    [drm:r100_cs_track_texture_print] *ERROR* bpp                        4
    [drm:r100_cs_track_texture_print] *ERROR* coordinate type            0
    [drm:r100_cs_track_texture_print] *ERROR* width round to power of 2  0
    [drm:r100_cs_track_texture_print] *ERROR* height round to power of 2 0
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    Textured video seems to work OK, but xine-ui's on-screen display still stops the X server from responding. Basically, the dmesg log fills up with messages like:
    Code:
    [drm:r100_cs_packet_parse] *ERROR* Packet (0:0:99) end after CS buffer (34) !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:r100_cs_packet_parse] *ERROR* Packet (0:0:99) end after CS buffer (90) !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    [drm:r100_cs_packet_parse] *ERROR* Packet (0:0:99) end after CS buffer (34) !
    [drm:radeon_cs_ioctl] *ERROR* Invalid command stream !
    and you become unable to click on anything any more, although you can still move the mouse pointer. Switching to a console and SIGHUPing the Xorg process restores control.
    Last edited by chrisr; 01-01-2010 at 11:31 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •