Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: HD 3850 agp

  1. #1
    Join Date
    Jan 2010
    Posts
    8

    Default HD 3850 agp

    Hi. I have this video card and Gentoo Linux. I downloaded driver from AMD site, installed it and get very high load cpu X in windows operations (60%-90%). I apply "backclear" patch and load cpu decreased, but not all windows operations. Now i install "radeon" driver and load cpu 20%-30%. I try install ati-driver from Gentoo portage and get this message:

    * You have DRM support built in to the kernel
    * Direct rendering will not work.
    * ati-drivers-9.11 requires MSI in the kernel.
    * Please enable it:
    * CONFIG_PCI_MSI=y
    * in /usr/src/linux/.config or
    * Bus options (PCI etc.) --->
    *[*] Message Signaled Interrupts (MSI and MSI-X)
    * in the kernel config.
    *
    * ERROR: x11-drivers/ati-drivers-9.11 failed.
    But i have agp card. Why PCI_MCI? What to do?

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,385

    Default

    The AGP 3850 card uses a PCIE GPU combined with a PCIE-to-AGP bridge chip, so it may use MSI interrupts between the GPU and the bridge chip, not sure.

    If you enable MSI in the kernel does the error message go away ?

  3. #3
    Join Date
    Jan 2010
    Posts
    8

    Default

    Quote Originally Posted by bridgman View Post
    The AGP 3850 card uses a PCIE GPU combined with a PCIE-to-AGP bridge chip, so it may use MSI interrupts between the GPU and the bridge chip, not sure.

    If you enable MSI in the kernel does the error message go away ?
    I have not found CONFIG_PCI_MSI in .config. Kernel 2.6.30

  4. #4
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Quote Originally Posted by Flame View Post
    I have not found CONFIG_PCI_MSI in .config. Kernel 2.6.30
    If it's left unchecked in the kernel config, it's doubtful that you will find it in the .config file.

  5. #5
    Join Date
    Jan 2010
    Posts
    8

    Default

    Quote Originally Posted by deanjo View Post
    If it's left unchecked in the kernel config, it's doubtful that you will find it in the .config file.
    Add manually?

  6. #6
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Quote Originally Posted by Flame View Post
    Add manually?

    Using xconfig is probably the easiest.

  7. #7
    Join Date
    Jan 2010
    Posts
    8

    Default

    Quote Originally Posted by deanjo View Post
    Using xconfig is probably the easiest.
    I can`t find this in menuconfig too.

  8. #8
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Quote Originally Posted by Flame View Post
    I can`t find this in menuconfig too.
    make menuconfig
    hit the '/' key and search for MSI

  9. #9
    Join Date
    Jan 2010
    Posts
    8

    Default

    Quote Originally Posted by deanjo View Post
    make menuconfig
    hit the '/' key and search for MSI
    I did it.

    Symbol: PCI_MSI [=n] │
    │ Prompt: Message Signaled Interrupts (MSI and MSI-X) │
    │ Defined at drivers/pci/Kconfig:8 │
    │ Depends on: PCI && ARCH_SUPPORTS_MSI │
    │ Location: │
    │ -> Bus options (PCI etc.) │
    │ Selected by: AMD_IOMMU && X86_64 && PCI && ACPI
    But i can`t find it in "Bus options"

  10. #10
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    Select Local APIC support on uniprocessors and see if it shows up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •