Results 1 to 8 of 8

Thread: Best 2d performance for VIA Chrome9?

  1. #1
    Join Date
    Nov 2008
    Posts
    13

    Default Best 2d performance for VIA Chrome9?

    I got a netbook with Vista installed from a friend who thought it was too slow to run.

    It has a sticker on it that shows that it came with SUSE10 to begin with, so I thought it would be easy to install any distro.

    The GPU is the VIA Chrome9. Now i ask with driver is currently the best for 2d preference? Surfing, watch video on youtube etc...

    Thanks
    Harald

  2. #2
    Join Date
    Apr 2008
    Posts
    325

    Default

    What netbook is it?

    I'm asking because a couple of the openchrome people have various netbooks around, so it gets tested on those, and they are really helpful with getting hardware working in my experience.

  3. #3
    Join Date
    Nov 2008
    Posts
    13

  4. #4
    Join Date
    Apr 2008
    Posts
    325

    Default

    I know it well, I have one. For myself, I run Gentoo with OpenChrome, and I know someone is running Fedora with OpenChrome. That said, Ubuntu has how-tos for the VIA driver, and OpenSUSE will almost certainly work well with VIA drivers as well.

    I would look through and see if your distro has a "How-To" for it, as that will probably give you a good idea what will work easiest.

  5. #5
    Join Date
    Nov 2008
    Posts
    13

    Default

    Ok, so the OpenChrome driver works well for 2D? Could you post your xorg.conf?

  6. #6
    Join Date
    Apr 2008
    Posts
    325

    Default

    openchrome gives good enough performance for me. YMMV. I have very little in the xorg.conf as all the defaults are sane enough for my usage.

  7. #7
    Join Date
    Mar 2009
    Location
    in front of my box :p
    Posts
    769

    Default

    Quote Originally Posted by RobbieAB View Post
    YMMV
    That is so true.

    @hirolau

    But at least openchrome (besides a VESA) works at all. Not sure about the specific chip here but the one in my CLE266 and CN700 basically work with it, though EXA (at least with KDE4) won't go (only XAA) and there is no 3d further than glxgears running slowly without crashing.
    One can mess up some thing by config, though. E.g. I finally managed to install a via framebuffer console on my Laptop (CLE266 VTsomething) but only with accel=0. Accelerated the penguin would show up but all text would be garbage.
    So at least I have basic 2d accel working, scrolling, MPEG2 works and that is something.

    For xorg.conf you should see man openchrome. (probably there after installation but should also float around the net).
    Lots of stuff you can tune, especially be careful with EXA. Might work better on your probably more recent chip, I don't know. 3d should be in mesa, but don't expect anything.


    Note: It might be Gentoo specific but xf86-video-via is kicked out (does not compile with recent xorg) and the unichrome is dead as well as it seems (not in Gentoo's portage).
    So there is either xf86-video-vesa (or the like) or, better, xf86-video-openchrome.
    NOTE: If you do self compiling you might want to check openchrome's svn. The releases have large timespans inbetween and even if it is not the most frequented place there is development going on in openchrome.

    If you want I can look on my laptop or search on the net for the commands to build. (basically svn fetch, make and install)

    So basically it works, doesn't consume much energy, the VIA CPU padlock stuff is a nice idea but don't expect any wonders from VIA hardware - especially with the current GPU-driver situation.

  8. #8
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,989

    Default

    While the last unichrome release was in 2006, last git activity was in Nov 2009. I would think Luc's code would be worth a try on the cle266.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •