Results 1 to 8 of 8

Thread: black screen during the boot

  1. #1
    Join Date
    Jun 2009
    Posts
    8

    Default black screen during the boot

    Hi everyone,

    i'm using fedora 12 with plymouth and i have a black screen during the boot. And it takes a long time when the display switch from off to on.

    I have an ATI 4870 and i'm using KMS with kernel 2.6.32 and radeon driver.

  2. #2
    Join Date
    Nov 2007
    Location
    Die trolls, die!
    Posts
    525

    Default

    same problem here
    as soon as KMS is supposed to kick in the screen goes black during boot.

    Kernel 2.6.32 with gentoo (but distri doesnt matter here I reckon)

    grafik adapter is a Radeon HD 4890 (rv770?)

  3. #3
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    This almost certainly means that something is interfering with the KMS framebuffer.

    Try disabling any framebuffer console you have in your kernel config. This usually helps.

  4. #4
    Join Date
    Jun 2009
    Posts
    8

    Default

    This almost certainly means that something is interfering with the KMS framebuffer.

    Try disabling any framebuffer console you have in your kernel config. This usually helps.
    Thanks

    but how do you disable framebuffer console?
    Last edited by Sly154; 01-11-2010 at 01:53 PM.

  5. #5
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,102

    Default

    Does the machine eventually get a display or does the screen remain black, forcing a manual reboot? If it's the latter, add me to the list. Have not figured out what's causing it.

  6. #6
    Join Date
    Jun 2009
    Posts
    8

    Default

    yes display is ok after the boot. the most annoying is the problem when the display goes on after it was suspended.
    Last edited by Sly154; 01-11-2010 at 02:32 PM.

  7. #7
    Join Date
    Dec 2007
    Posts
    2,372

    Default

    2.6.32.2 kms is broken on r6xx+. fix is in 2.6.32.3. Also you need fbcon loaded to get a console on the radeon drm framebuffer.

  8. #8
    Join Date
    Jun 2009
    Posts
    8

    Default

    Ok thanks, i will update my kernel when i have the time.
    I tried with the kernel 2.6.31.9 provided with fedora and it's the same result.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •