Results 1 to 5 of 5

Thread: Debian on PPC - missing external packages and other issues

  1. #1
    Join Date
    Nov 2009
    Posts
    15

    Default Debian on PPC - missing external packages and other issues

    Ubuntu vs. Debian:

    Since Phoronix seems to support Ubuntu best, I tried to stick with it.

    Although its not officially supported, I tried to install Ubuntu 9.10 on my e500 core PPC. I was able to complete the base installation, but both aptitude and apt-get would fail with Illegal Instruction traps. It turns out that the issue was that the e500 core doesn't support the full PPC instruction set. The code must be compiled with the GCC gnuspe settings and I wasn't able to find an Ubuntu PPC repository with gnuspe settings.

    I found a Debian (Lenny) PPC repository with gnuspe settings, so I installed Debian and it works very well! The Phoronix Test Suite installed on the Debian system perfectly. It runs in CLI mode just fine.

    Phoronix Test Suite issues:

    Although the Phoronix Test Suite framework works flawlessly, there are a few issues with some test profiles:

    When installing the AIO-Stress test profile, PTS says that the external packages libaio-dev and libaio-devel must be installed first. I was able to install libaio-dev, but absolutely no Debian repository has a package called libaio-devel.

    When installing the x11perf test profile, PTS says that the external packages xserver-xorg-development and xorg-devel must be installed first. No Debian repository has packages called xserver-xorg-development or xorg-devel.

    When running the hdparm-read test profile the following error is generated:

    /usr/share/phoronix-test-suite/pts-core/test-libraries/root-access.sh: /tmp/tmp.<sequence of 9 random alphabetic characters>: /bin/sh\n\n. /hdparm-read: bad interpreter: no such file or directory.

    The geekbench test profile initially caused an infinite kernel loop. It probably can't run on an e500 core PPC system, unless it could be recompiled for it.

    I'd like to run PTS in its GUI mode, but wasn't able to find a php5-gtk2 package for Debian. Could the Ubuntu php5-gtk2 package be made to work without too much manually intervention? Would compiling php5-gtk2 from source be a better option?

    Thanks,

    Ken Fuchs
    Last edited by fuchsk; 01-13-2010 at 04:55 PM. Reason: Added minor corrections and Ubuntu and Debian versions

  2. #2

    Default

    Are you referring to the package names by what it says? When its running on an unsupported distribution it does not know what the package name actually is (hence its unsupported), so it just reports some of the common package names, in hopes you will be able to more easily find the package that's needed. So if you have libaio-dev is what it is called on Ubuntu/Debian, libaio-devel is what it is on Fedora, etc.

    The hdparm error is likely a PowerPC incompatibility issue.

    GeekBench is proprietary software so unfortunately without the source to it we can't recompile it.

    I don't know of any php5-gtk package for PowerPC, so you'd need to build from source @ http://gtk.php.net/

  3. #3
    Join Date
    Nov 2009
    Posts
    15

    Default

    Quote Originally Posted by Michael View Post
    Are you referring to the package names by what it says? When its running on an unsupported distribution it does not know what the package name actually is (hence its unsupported), so it just reports some of the common package names, in hopes you will be able to more easily find the package that's needed. So if you have libaio-dev is what it is called on Ubuntu/Debian, libaio-devel is what it is on Fedora, etc.
    Thanks for the explanation. I mistakenly thought that Debian would be supported, because Ubuntu is based on Debian and Ubuntu is supported.

    I got the external dependencies installed and the affected tests are working now.

    Quote Originally Posted by Michael View Post
    The hdparm error is likely a PowerPC incompatibility issue.
    I tried running "hdparm-read -t /dev/sda" in the installed-tests/hdparm directory and it seems to work fine (reported about 75 MB/sec performance). By adding debugging statements I see that the scripts do issue "hdparm-read -t /dev/sda", so perhaps the Enviroment is at fault some how? It seems that the scripts are not working correctly and I will continue to investigate this issue.

    Thanks,

    Ken Fuchs

  4. #4

    Default

    Quote Originally Posted by fuchsk View Post
    Thanks for the explanation. I mistakenly thought that Debian would be supported, because Ubuntu is based on Debian and Ubuntu is supported.
    Debian is actually supported, but I am wondering if it's hitting something weird on PPC. I have no access to PPC hardware so I am not certain. Would you mind posting your: phoronix-test-suite system-info and phoronix-test-suite diagnostics outputs?

  5. #5
    Join Date
    Nov 2009
    Posts
    15

    Default A solution to the issue; some commentary on the state of echo

    Quote Originally Posted by Michael View Post
    Debian is actually supported, but I am wondering if it's hitting something weird on PPC. I have no access to PPC hardware so I am not certain. Would you mind posting your: phoronix-test-suite system-info and phoronix-test-suite diagnostics outputs?
    # phoronix-test-suite system-info
    ...
    Network Communication Is Disabled.


    ====================================
    Phoronix Test Suite v2.2.0 (Bardu)
    System Information
    ====================================

    Hardware:
    Processor: Unknown (Total Cores: 1), Motherboard: Unknown, Chipset: Unknown, System Memory: 1010MB, Disk: 80GB ST380815AS + 64GB TS64GSSD25S-M, Graphics: ATI Radeon X300 (RV370) 5B60 (PCIE) 128MB, Monitor: DELL E773s

    Software:
    OS: Linux, Kernel: 2.6.31-14-powerpc (ppc), Desktop: GNOME 2.22.3, Display Server: X.Org Server 1.4.2, OpenGL: N/A, Compiler: GCC 4.3.2, File-System: ext2/ext3, Screen Resolution: Unknown

    #

    ---

    # phoronix-test-suite diagnostics

    Warning: file_get_contents(http://www.phoronix-test-suite.com/g...2.0&os=linux): failed to open stream: Connection refused in /usr/share/phoronix-test-suite/pts-core/library/pts-functions_basic.php on line 91

    Warning: file_get_contents(http://www.phoronix-test-suite.com/PTS): failed to open stream: Connection refused in /usr/share/phoronix-test-suite/pts-core/library/pts-functions_basic.php on line 91

    Network Communication Is Disabled.


    ====================================
    Phoronix Test Suite v2.2.0
    Diagnostics Output
    ====================================

    PTS_PATH = /usr/share/phoronix-test-suite/
    PTS_MODE = CLIENT
    PTS_LIBRARY_PATH = /usr/share/phoronix-test-suite/pts-core/library/
    PTS_VERSION = 2.2.0
    PTS_BUILD_INT = 2200
    PTS_CODENAME = BARDU
    PTS_MODULE_UNLOAD = PTS_MODULE_UNLOAD
    PTS_QUIT = PTS_QUIT
    QUICK_START =
    PTS_CORE_PATH = /usr/share/phoronix-test-suite/pts-core/
    PTS_USER_DIR = /root/.phoronix-test-suite/
    PTS_CORE_STORAGE = /root/.phoronix-test-suite/core.pt2so
    XML_DISTRO_DIR = /usr/share/phoronix-test-suite/pts/distro-xml/
    SCRIPT_DISTRO_DIR = /usr/share/phoronix-test-suite/pts/distro-scripts/
    MODULE_DIR = /usr/share/phoronix-test-suite/pts-core/modules/
    MODULE_LOCAL_DIR = /root/.phoronix-test-suite/modules/
    DEFAULT_DOWNLOAD_CACHE_DIR = /root/.phoronix-test-suite/download-cache/
    RESULTS_VIEWER_DIR = /usr/share/phoronix-test-suite/pts-core/results-viewer/
    TEST_LIBRARIES_DIR = /usr/share/phoronix-test-suite/pts-core/test-libraries/
    STATIC_DIR = /usr/share/phoronix-test-suite/pts-core/static/
    OPTIONS_DIR = /usr/share/phoronix-test-suite/pts-core/options/
    XML_PROFILE_DIR = /usr/share/phoronix-test-suite/pts/test-profiles/
    XML_PROFILE_CTP_BASE_DIR = /usr/share/phoronix-test-suite/pts/base-test-profiles/
    XML_SUITE_DIR = /usr/share/phoronix-test-suite/pts/test-suites/
    TEST_RESOURCE_DIR = /usr/share/phoronix-test-suite/pts/test-resources/
    TEST_RESOURCE_CTP_BASE_DIR = /usr/share/phoronix-test-suite/pts/base-test-resources/
    XML_PROFILE_LOCAL_DIR = /root/.phoronix-test-suite/test-profiles/
    XML_SUITE_LOCAL_DIR = /root/.phoronix-test-suite/test-suites/
    TEST_RESOURCE_LOCAL_DIR = /root/.phoronix-test-suite/test-resources/
    PHP_BIN = php5
    PTS_INIT_TIME = 1263593123
    PHODEVI_AVOID_CACHE = 0
    PHODEVI_STAND_CACHE = 1
    PHODEVI_SMART_CACHE = 2
    OPERATING_SYSTEM = Linux
    OS_PREFIX = linux_
    PTS_GSID =
    TEST_ENV_DIR = /root/.phoronix-test-suite/installed-tests/
    SAVE_RESULTS_DIR = /root/.phoronix-test-suite/test-results/
    PTS_USER_LOCK = /root/.phoronix-test-suite/run_lock
    NO_NETWORK_COMMUNICATION = 1
    PTS_STARTUP_TASK_PERFORMED = 1

    End-User Run-Time Variables:
    VIDEO_RESOLUTION = Unknown
    VIDEO_CARD = ATI Radeon X300 (RV370) 5B60 (PCIE) 128MB
    VIDEO_DRIVER =
    OPERATING_SYSTEM = Linux
    PROCESSOR = Unknown (Total Cores: 1)
    MOTHERBOARD = Unknown
    CHIPSET = Unknown
    KERNEL_VERSION = 2.6.31-14-powerpc
    COMPILER = GCC 4.3.2
    HOSTNAME = Lenny-SPE

    Environmental Variables (accessible via test scripts):
    PTS_VERSION = 2.2.0
    PTS_CODENAME = BARDU
    PTS_DIR = /usr/share/phoronix-test-suite/
    PHP_BIN = php5
    NUM_CPU_CORES = 1
    NUM_CPU_JOBS = 2
    SYS_MEMORY = 1010
    VIDEO_MEMORY = 128
    VIDEO_WIDTH = -1
    VIDEO_HEIGHT = -1
    VIDEO_MONITOR_COUNT = 1
    VIDEO_MONITOR_LAYOUT = CENTER
    VIDEO_MONITOR_SIZES = Unknown
    OPERATING_SYSTEM = linux
    OS_VERSION = Unknown
    OS_ARCH = ppc
    OS_TYPE = Linux
    THIS_RUN_TIME = 1263593123
    DEBUG_REAL_HOME = /root/

    #

    *** A Solution ***

    I found the root cause of this issue (hdparm-read failure on some systems).

    The echo commands in the root-access.sh script require the -e option which enables escape sequences. This is a confusing aspect of GNU echo, since echo is often implemented by the shell itself. Shell implemented echo and non-GNU echo commands often enable escape sequences by default. Some echo commands will treat a -e option as an invalid option rather than sanely ignore it. Thus there is really no alternative (which may be changing - see next paragraph), but to check which version of echo will in invoked in scripts and add or not add the -e option as appropriate.

    However, I suspect that echo on any GNU/Linux system (this probably excludes BusyBox/Linux systems) will either require the -e option or gracefully ignore it, so just adding the -e option to any echo command with escape squences in the arguments should work fine. Be careful of xBSD systems whose echo will interpret escape sequences by default and may or may not ignore a -e option (generating an error as a result).

    Possibly do to the predominance of GNU echo, I suspect that modern versions of shell and non-GNU echo commands will ignore the -e option without causing a fatal error.

    Sincerely,

    Ken Fuchs
    Last edited by fuchsk; 01-15-2010 at 11:23 AM. Reason: Added minor clarification; added system-info and diagnostic data.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •