Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: mesa git compile error

  1. #1
    Join Date
    Apr 2009
    Posts
    6

    Default mesa git compile error

    Anyone else having trouble compiling mesa lately, last few week are so
    I've been getting the following error

    gcc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa -I../../../src/mesa/glapi -I/usr/include/drm -O2 -march=native -Wall -Wmissing-prototypes -std=c99 -ffast-math -fno-strict-aliasing -fPIC -DUSE_X86_64_ASM -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/lib/dri\" glxcurrent.c -o glxcurrent.o
    gcc -c -I. -I../../../include -I../../../include/GL/internal -I../../../src/mesa -I../../../src/mesa/glapi -I/usr/include/drm -O2 -march=native -Wall -Wmissing-prototypes -std=c99 -ffast-math -fno-strict-aliasing -fPIC -DUSE_X86_64_ASM -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DGLX_DIRECT_RENDERING -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS -DXF86VIDMODE -D_REENTRANT -UIN_DRI_DRIVER -DDEFAULT_DRIVER_DIR=\"/usr/lib/dri\" glxext.c -o glxext.o
    glxext.c: In function '__glXWireToEvent':
    glxext.c:166: error: 'xGLXBufferSwapComplete' undeclared (first use in this function)
    glxext.c:166: error: (Each undeclared identifier is reported only once
    glxext.c:166: error: for each function it appears in.)
    glxext.c:166: error: 'awire' undeclared (first use in this function)
    glxext.c:166: error: expected expression before ')' token
    make: *** [glxext.o] Error 1

  2. #2
    Join Date
    Dec 2009
    Posts
    40

    Default

    Quote Originally Posted by Waltarro View Post
    Anyone else having trouble compiling mesa lately
    For what it's worth, no. I'm using mesa-9999 from the x11 overlay on Gentoo, which I recompile several times a week and I haven't gotten any error lately.

  3. #3
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    You might need to upgrade your X or some other part of your system.

  4. #4
    Join Date
    Oct 2007
    Posts
    1,277

    Default

    The requirements for mesa were recently increased to glproto 1.4.11 and dri2proto 2.2

    Try doing a 'make distclean' and re-running autogen. You'll probably get errors unless you have recent enough versions of that stuff. I know that Debian sid/unstable doesn't even have recent enough versions yet.

  5. #5
    Join Date
    Jan 2010
    Posts
    7

    Default same here

    I upgraded to the dri2proto 2.2 and glproto (both from git) and get the same error.
    Mesa used to build OK until a few days ago.

    Any ideas?

  6. #6
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    Have you tried a clean checkout?

  7. #7
    Join Date
    Jan 2010
    Posts
    7

    Default

    You expect a git bug?
    Just did the fresh checkout.
    No change.

  8. #8
    Join Date
    Jan 2010
    Posts
    7

    Default

    # find . -type f -exec grep -H xGLXBufferSwapComplete {} \;./src/glx/x11/glxext.c: xGLXBufferSwapComplete *awire = (xGLXBufferSwapComplete *)wire;

    So it is only missed once.

  9. #9
    Join Date
    Jan 2010
    Posts
    7

    Default

    Even google finds xGLXBufferSwapComplete only once.

  10. #10
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,111

    Default

    I have that definition in glxproto.h, coming from glproto 1.4.11.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •