Finally some good news. I figured out a workaround to the whole backlighting control issue. And maybe this was something the OP already was doing but was not really clear so I'm going to explicitly spell them out here. I want to stress that this is a working convfiguration for me, ymmv applies.

1) In the BIOS, enable dual screen clone mode:
Advanced -> IGD Mode -> [LCD-1-2]
save and exit [F10]

This will turn on the backlighting for the right screen.

2) I'm on 2.6.32.8 kernel and xorg-server 1.75. If someone needs the kernel config, drop me a line, I'm still tuning.

Hopefully when the 1.8 line comes out, this won't need to be repeated all over again.

3) remove /etc/X11/xorg.conf, let dbus and/or HAL do their thing. Going to let the whole dbus/HAL settle before I start playing around with X parameters. The defaults seems to be working ok, but I'm sure there could be some optimized settings to increase battery life and/or performance.

4) compile from git the following packages (working as of 2010-02-19):
dri2-proto
glproto
libdrm
xf86-video-ati
mesa

5) startx and hopefully you'll have cloned desktops on both screens.

6) xrandr --output DVI-0 --right-of LVDS

at this point, you should have an expanded desktop.

Now to figure out the following ACPI messages spamming my logs:

ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPC0.EC0_._Q11] (Node ffff88016181f980), AE_NOT_FOUND
ACPI Error (psargs-0359): [\_TZ_.TZ01] Namespace lookup failure, AE_NOT_FOUND