Results 1 to 3 of 3

Thread: R700 KMS with non-git packages

  1. #1
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,790

    Default R700 KMS with non-git packages

    Is it possible to get KMS working with a Radeon HD4870 in X.Org with non-git Mesa/X.Org/etc? KMS works for the fbcon, but not with X, I get the

    [dri] radeon kernel module version is 2.0.0 but version 1.17.0 or newer is needed.

    error when starting X and the display hangs. I pretty much have the latest versions installed:

    Kernel 2.6.33 rc4 (R700_rlc.bin build into the kernel)
    libdrm 2.4.17 (libdrm_radeon enabled)
    Mesa 7.7 (Gallium3D disabled)
    X.Org 7.5 (1.7.4)
    xf86-video-ati 6.12.4

    Possible to get X+KMS working with those versions?

    (I don't really *need* KMS, but it seems DRI2, which *is* what I need, is unusable without it.)

  2. #2
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    For radeon, DRI2 requires KMS. So you need the latest xf86-video-ati and mesa 3D drivers in order to use KMS.

  3. #3
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,790

    Default

    OK, I was able to use KMS with just xf86-video-ati from Git. Mesa and all other packages were regular releases.

    Looks nice. I disabled it again though since ForceLowPowerMode doesn't work yet with KMS and after a while (an hour or so) graphical glitches start to show up:

    http://i46.tinypic.com/20pa4yc.png
    http://i48.tinypic.com/12479kw.png

    Some of the black and yellow areas even start to flash widly.
    Last edited by RealNC; 01-18-2010 at 04:33 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •