Hi, my first time posting to Phoronix. I posted about this issue in the Ubuntu forums, but so far no replies. I was hoping the graphics experts here might be able to shed some light ...

I have been using onboard graphics, the open-source driver ati and a rotated display successfully ever since installing Ubuntu 10.10. After installing a new graphics card (ATI Radeon HD 5670), I find that when I attempt to rotate one of my displays, both go blank for a few seconds, then display the login screen.

I tried creating a new user and applying changes to my display configuration one-by-one. When I got to rotation, I got a blank screen then a login screeen. I tried rotating from the command line with xrandr. Same result as the GUI.

I tried recovery mode, and when I chose failsafeX, my monitors went blank and nothing else. I gave up waiting.

I tried creating a xorg.conf and specifying rotation for one of the monitors in there. (I did not use a xorg.conf before.) My monitors went blank instead of going to the login screen.

I disabled my onboard graphics in BIOS to prevent any confusion.

I looked through my logs to see if I could spot any error messages. I found things like (pasted from various logs):
Code:
[   13.054571] radeon 0000:01:05.0: Error during ACPI methods call
Feb 22 00:18:27 Puck kernel: [ 1161.871617] radeon 0000:01:05.0: ffff8800a1c44c00 reserve failed for wait
[ 10900.113] (EE) RADEON(0): [DRI2] DRI2SwapComplete: bad drawable
but not sure if they are helpful. I searched on some of these errors and didn't see anything similar to my problem.

Does anyone have any idea what's going on? Is there any more information I can provide?