Page 7 of 24 FirstFirst ... 5678917 ... LastLast
Results 61 to 70 of 240

Thread: Radeon Gallium on ubuntu

  1. #61
    Join Date
    Oct 2007
    Posts
    1,283

    Default

    I'm currently toying with getting a PPA that has gallium enabled to make it easy for people to test. In theory, all I should need to do is depend on the xorg-edgers PPA, copy the version of mesa from there, and add the --enable-gallium-radeon flag to my PPA's version of mesa, no?

    Well, I got it to build, and I'm about to test it (although I don't have an r300-r500 card at the moment). If anyone's interested, I have Lucid version right now: https://launchpad.net/~dtl131/+archive/mediahacks

  2. #62
    Join Date
    Dec 2009
    Posts
    134

    Default

    I have an ATI 1800XL (R520), I will install your PPA at my home computer and try it. I hope I do not screw up something. How do I get upates for the latest Gallium3D mesa? I have the Xorg Edgers crak ppa installed. Do you I get auto update?

  3. #63
    Join Date
    Dec 2009
    Posts
    134

    Default

    How to install it? I could not download said package, and synaptic could not find your pack after I did add your source ppa

  4. #64
    Join Date
    Oct 2007
    Posts
    1,283

    Default

    Quote Originally Posted by Beiruty View Post
    How to install it? I could not download said package, and synaptic could not find your pack after I did add your source ppa
    I think the edgers PPA version deprecated mine. You could probably select it in Synapitc under the versions tab. Unfortunately, I would advise you to build from source if you want to try gallium because I'm going to be away from the computer world for a while because of medical issues.

  5. #65
    Join Date
    Aug 2007
    Posts
    30

    Default

    Hi,
    I've a 9600XT (RV350), latest mesa git, latest libdrm (git), gentoo-sources-2.6.33, xorg-server 1.7.6


    OpenGL vendor string: X.Org R300 Project
    OpenGL renderer string: Gallium 0.4 on RV350
    OpenGL version string: 1.5 Mesa 7.9-devel
    >> nexuiz is sloooooooooow (can't really move the mouse..), and I think "OpenGL version string:" should be 2.0 or something like that.. any ideas?

    Thx!

  6. #66
    Join Date
    Dec 2009
    Posts
    338

    Default

    Quote Originally Posted by Dragonix View Post
    Hi,
    and I think "OpenGL version string:" should be 2.0 or something like that.. any ideas?
    Gallium reports OpenGL 2.0 only on r500 cards as far as I know. I think Marek said it somewhere but I'm too lazy to look it up.

  7. #67
    Join Date
    Aug 2007
    Posts
    30

    Default

    Quote Originally Posted by HokTar View Post
    Gallium reports OpenGL 2.0 only on r500 cards as far as I know. I think Marek said it somewhere but I'm too lazy to look it up.
    ah ok, thanks, that explains the opengl-1.5... though.. shouldn't i be able to play nexuiz? I mean, I can start nexuiz, but than everything is to slow (as already told, i can't move the mouse/exit nexuiz/..).

  8. #68
    Join Date
    Dec 2009
    Posts
    338

    Default

    Quote Originally Posted by Dragonix View Post
    ah ok, thanks, that explains the opengl-1.5... though.. shouldn't i be able to play nexuiz? I mean, I can start nexuiz, but than everything is to slow (as already told, i can't move the mouse/exit nexuiz/..).
    Dunno about nexuiz. However, openarena is reported to be working nicely, so you should try that one just to check if your setup is working correctly. If it does then you might try to report the problem with nexuiz on dri-devel.

  9. #69
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    IIRC there are a couple of effects which need to be turned off for Nexuiz to run fast on <GL 2.0 - bloom was one, forget the other.

  10. #70
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,104

    Default

    Motion Blur as well I think.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •