Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Phoronix Test Suite 2.4 Released

  1. #11
    Join Date
    Aug 2007
    Posts
    6,673

    Default

    You can read about it since months and the formal reason why the Linux version was delayed are fglrx problems. There is fglrx 10-1 out and still no word about an Unigene Heaven Linux version. Do we need to wait until fglrx 10-12 or is the new excuse that you can not buy Nv hardware with tesselation yet? Also when you have got only 1 PTS profile you would need later two, one with tesselation and one without.

  2. #12

    Default

    Quote Originally Posted by Kano View Post
    Also when you have got only 1 PTS profile you would need later two, one with tesselation and one without.
    No, it's already made available as a PTS run-time option to init the engine with tessellation support or not.

  3. #13
    Join Date
    Aug 2007
    Posts
    6,673

    Default

    Ok, just enable download to your own copy.

  4. #14
    Join Date
    Jul 2008
    Location
    Colorado Springs
    Posts
    23

    Default

    I formatted my machine and upgraded to Ubuntu 9.10 from 8.10. Then I installed the 2.4 release version of Phoronix.

    I probably should add my name to the 10.04 alpha test.... especially since I have an ATI 5870 now.

    I am using the symbolic link option instead of copying from the cache. Nice. I can easily install the cache on my BIG drive and then install and bench using a 50Gb raid-0 partition.


    ISSUES: (You already knew about some of these: but I'm just repeating what I found.)

    NOTE: I had to manually create a symbolic link from libstdc++.so.5 to libstdc++.so.6.0.13 or it attempted to re-install libstdc++.so.5 every time I ran anything.


    1. Ran into either a copy or link problem with the soccer source file used by the x264 test. But it took me awhile to figure this out and then go and download the file manually and put it into my cache directory. This is probably a non-issue and might have been my fault for messing with the symbolic and/or delete options.

    2. The file disk.xml file in the pts/test-suites directory shows two "Dbench" runs at 48 clients. The second "48" run has a description of "128 clients"... so I assume that run of the test should have 128 as the actual parameter being passed and not 48.

    3. I had to patch the encode-ape to work. Basically I had to insert some casts in two files to make the application compile. I made a diff file if you would like it: It is included in a code section at the end of this post. (For testing: I changed the two files, then re-compressed the install file and upated the md5sum and size in the xml files so the fixed file in my download cache would work.)

    4. The minion script is trying to run the command "minion", but it appears that only the "minion-quick" command is available in that test's build directories. To test this I changed the phoronix script to run the minion-quick and that seemed to work.

    5. super-pi no longer runs. Not a great loss. With Ubuntu 9.10 on AMD64 it just dumps.

    6. smokin-guns still broken because of an issue with libXxf86dga.so.1 even though that file is in /usr/lib.

    7. UT2004 no longer works. If you go in and run the executable by itself i throws an error talking about GLIBCPP_3.2 and CXXABI_1.2 errors. I didn't really look further... but it seems to be version problems.

    8. fio: The tests seems to work but the phoronix test fails after running for awhile. I haven't tracked this problem down. I have 12Gb available on the test drive; I wonder if it is drive free space.






    IN CASE YOU WANT IT: THE FIX DIFF FOR ENCODING-APE:
    Code:
    diff -Naur mac-3.99-u4-b5-s4/src/MACLib/APECompressCreate.cpp.ORIG mac-3.99-u4-b5-s4/src/MACLib/APECompressCreate.cpp
    --- mac-3.99-u4-b5-s4/src/MACLib/APECompressCreate.cpp.ORIG	2010-02-03 14:51:07.390761759 -0700
    +++ mac-3.99-u4-b5-s4/src/MACLib/APECompressCreate.cpp	2010-02-03 14:51:24.970761406 -0700
    @@ -279,14 +279,14 @@
             nDataSize = (((nNumberOfFrames - 1) * m_nSamplesPerFrame + nFinalFrameBlocks) * m_wfeInput.nBlockAlign);
             for (i = 0; i < nHeaderBytes; i++)
             {
    -            if ((p = strstr((const char *)pHeaderData+i,"RIFF"))) {
    +            if ((p = strstr((char *)pHeaderData+i,"RIFF"))) {
                     ULONG_TO_UCHAR_LE((unsigned char *)p+4,nDataSize + nHeaderBytes - 8);
                     break;
                 }
             }
             for (i = 0; i < nHeaderBytes; i++)
             {
    -            if ((p = strstr((const char *)pHeaderData+i,"data"))) {
    +            if ((p = strstr((char *)pHeaderData+i,"data"))) {
                     ULONG_TO_UCHAR_LE((unsigned char *)p+4,nDataSize);
                     break;
                 }
    diff -Naur mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp.ORIG mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp
    --- mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp.ORIG	2010-02-03 14:51:51.020760771 -0700
    +++ mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp	2010-02-03 14:52:21.320762024 -0700
    @@ -63,10 +63,10 @@
         if (pData != NULL)
         {
             // parse out the information
    -        char * pHeader = strstr(pData, APE_LINK_HEADER);
    -        char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
    -        char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
    -        char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
    +        char * pHeader = (char *) strstr(pData, APE_LINK_HEADER);
    +        char * pImageFile = (char *) strstr(pData, APE_LINK_IMAGE_FILE_TAG);
    +        char * pStartBlock = (char *) strstr(pData, APE_LINK_START_BLOCK_TAG);
    +        char * pFinishBlock = (char *) strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
     
             if (pHeader && pImageFile && pStartBlock && pFinishBlock)
             {

  5. #15

    Default

    Thanks for the feedback. Will comment more when I get back to the office.

  6. #16
    Join Date
    Jul 2008
    Location
    Colorado Springs
    Posts
    23

    Default

    ADDENDUM:

    FIO fails with this error: fio: file hash not empty on exit

    (Perhaps I'm having a problem with my drive? I'll try another one.)

  7. #17

    Default

    keithlm: Some of your symbolic link issues can be resolved if you simply reset your test directory in the configuration file rather than relying upon a symbolic link. Just modify it in ~/.phoronix-test-suite/user-config.xml.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •