Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: No-backfill still needed?

  1. #1
    Join Date
    Feb 2009
    Posts
    58

    Default No-backfill still needed?

    I was thinking of reinstalling Ubuntu 9.10 and was wondering if the no-backfill X-server patch was still needed for "a lag free experience with Compiz" if I use Catalyst 10.1 together with my HD4870?

  2. #2
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,156

    Default

    Not the backfill, but the newer backclear patch is needed.

    I hear this problem is going to get fixed in a future Catalyst driver release

  3. #3
    Join Date
    Feb 2009
    Posts
    58

    Default

    Ah, silly me. I was actually thinking of the backclear patch :P

    Thanks.

  4. #4
    Join Date
    Oct 2008
    Posts
    62

    Default

    Here on opensuse 11.2 the backclear patch is still needed.

  5. #5
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,104

    Default

    Quote Originally Posted by d2kx View Post
    Not the backfill, but the newer backclear patch is needed.

    I hear this problem is going to get fixed in a future Catalyst driver release

    A new 2D acceleration mechanism has gone into the 10.2 and 10.3 betas and is in testing. Supposedly it improves performance under composite window managers, but I haven't been able to test it due to unrelated issues in the drivers. They seem to be targeting Compiz, but I expect kwin will also see improvements. Hopefully everything pans out in the end.

  6. #6
    Join Date
    Apr 2010
    Posts
    19

    Exclamation

    FYI I just installed ubuntu 10.04 with the catalyst drivers v10.3 which came out just yesterday and the no-backfill problem is still there...

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    You probably want the backclear patch, not the no-backfill patch.

  8. #8
    Join Date
    Apr 2010
    Posts
    19

    Default

    Quote Originally Posted by bridgman View Post
    You probably want the backclear patch, not the no-backfill patch.
    why are u saying that? I have exactly the same issue with maximizing/minimizing windows in compiz

  9. #9
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Are you using the backclear patch ?

  10. #10
    Join Date
    Apr 2010
    Posts
    16

    Default

    It is still needed unless you enable this new 2D acceleration method. It's called 'Direct2D'
    1. Kill the x server
    2. Open /etc/ati/amdpcsdb, and under the section [AMDPCSROOT/SYSTEM/DDX]
    add:
    Direct2DAccel=STRUE
    3. Reboot (just in case)

    It's still on testing, but its getting pretty stable, at least for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •