Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: direct rendering no?

  1. #1
    Join Date
    Feb 2010
    Posts
    9

    Default direct rendering no?


    Last week , i found a post in http://forum.ubuntu.org.cn/viewtopic.php?f=94&t=239467, which told you how to enable 3D acceleration through installing the latest Open Source ATI drivers.So i follow it step by step as bellow:

    1. Download kernel *.deb from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32/ then install .
    2. Restart the computer , select the 2.6.32 entry in the grub menu, then edit /etc/source.list , add the follow two line:
    deb http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu karmic main
    deb-src http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu karmic main
    3. Install
    sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 0x4f191a5a8844c542
    sudo apt-get update && sudo apt-get upgrade
    4. Restart.

    After that , i enter the follow comand to test:
    ~ > glxinfo | grep render
    direct rendering: No (LIBGL_ALWAYS_INDIRECT set)
    OpenGL renderer string: Mesa DRI R600 (RV620 95C4) 20090101 x86/MMX/SSE2 TCL

    so why direct rendering is no? Does it mean 3D acceleration has not been enabled?
    how to solve it ? I didn't install any other ati drivers .

    notebook: Thinkpad T400 , ATI Mobility Radeon HD 3470 , Ubuntu 9.10 ,Kernel: 2.6.32-020632-generic

    ~ > lspci | grep VGA
    01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3400 Series

  2. #2
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,382

    Default

    Can you pastebin your xorg log and dmesg output ?

  3. #3
    Join Date
    Aug 2009
    Posts
    122

    Default

    >direct rendering: No (LIBGL_ALWAYS_INDIRECT set)

    that answers all questions.

  4. #4
    Join Date
    Feb 2010
    Posts
    9

    Default

    Quote Originally Posted by bridgman View Post
    Can you pastebin your xorg log and dmesg output ?
    Sure, but wait a minute , i restart and then switch to ubuntu

  5. #5
    Join Date
    Feb 2010
    Posts
    9

    Default

    Quote Originally Posted by netkas View Post
    >direct rendering: No (LIBGL_ALWAYS_INDIRECT set)

    that answers all questions.
    Thanks,but i can't understand what it means?

  6. #6
    Join Date
    May 2007
    Posts
    352

    Default

    You have disabled direct rendering. Most likely you are running some window manager that requires LIBGL_ALWAYS_INDIRECT to be set, and spawned a terminal from that window manager.

    If you run a terminal from your gnome menu, does glxinfo report direct rendering? Your renderer string is correct, so I'm willing to bet that everything is fine.

    Adam

  7. #7
    Join Date
    Dec 2007
    Posts
    2,315

    Default

    LIBGL_ALWAYS_INDIRECT forces all rendering to be indirect which is why you are seeing "direct rendering: No". Unset that env var, and you should get direct rendering. Note that you can still get hw acceleration with indirect rendering; indirect just means the 3d commands are sent to the xserver via GLX and then from the xserver to the 3D driver rather than send to directly to the 3D driver.

  8. #8
    Join Date
    Feb 2010
    Posts
    9

    Default

    Quote Originally Posted by bridgman View Post
    Can you pastebin your xorg log and dmesg output ?
    Sorry, the log file is too long to paste in the post , i paste here

    # /var/log/Xorg.0.log
    http://pastebin.com/m7119d0d9

    # dmseg
    http://pastebin.com/m466d8fe

  9. #9
    Join Date
    Feb 2010
    Posts
    9

    Default

    Quote Originally Posted by tuantuan View Post
    Sure, but wait a minute , i restart and then switch to ubuntu
    The log is too long to paste here ><
    #dmesg
    http://pastebin.com/m466d8fe

    #/var/log/Xorg.0.log
    http://pastebin.com/m7119d0d9

  10. #10
    Join Date
    Feb 2010
    Posts
    9

    Default

    Quote Originally Posted by adamk View Post
    You have disabled direct rendering. Most likely you are running some window manager that requires LIBGL_ALWAYS_INDIRECT to be set, and spawned a terminal from that window manager.

    If you run a terminal from your gnome menu, does glxinfo report direct rendering? Your renderer string is correct, so I'm willing to bet that everything is fine.

    Adam
    Ah..... That's right...
    When i open the terminal form the menu , the result is :
    ~ > glxinfo|grep render
    IRQ's not enabled, falling back to busy waits: 2 0
    direct rendering: Yes
    OpenGL renderer string: Mesa DRI R600 (RV620 95C4) 20090101 x86/MMX/SSE2 TCL

    but if i open a terminal with keyborad shortcuts, that is , "win+T"
    the result is "no" again ..

    also i use conky ? this affects?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •