Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 56

Thread: Recommended xorg.conf setup for radeonhd on Mobility Radeon X1400

  1. #11
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,795

    Default

    You asked how to make sure X uses your xorg.conf. My answer means that you should copy it as /etc/X11/xorg.conf

    Then, after X has started, this:

    grep xorg.conf /var/log/Xorg.0.log

    Should say:

    (==) Using config file: "/etc/X11/xorg.conf"

  2. #12

    Default

    Quote Originally Posted by RealNC View Post
    You asked how to make sure X uses your xorg.conf. My answer means that you should copy it as /etc/X11/xorg.conf
    Right, sorry, I'm doing that right now, and got the expected (==) Using config file: "/etc/X11/xorg.conf" message.

    So, now I'm certain I'm using radeon instead of radeonhd, but nothing has changed yet.

  3. #13
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,795

    Default

    OpenGL is quite slow with the open source drivers so make sure your media player uses Xv instead of OpenGL for video. The open drivers have a very good, stable, correct and fast Xv implementation.

    Also, it's best to not have any options in the device section of your X.Org conf. Here is an xorg.conf you can use as-is for the radeon driver:

    Code:
    Section "ServerLayout"
    	Identifier     "Simple Layout"
    	Screen      0  "Screen 1" 0 0
    EndSection
    
    
    Section "Monitor"
    	Identifier   "Monitor[0]"
    EndSection
    
    
    Section "Device"
    	Identifier  "X1400"
    	Driver      "radeon"
    EndSection
    
    
    Section "Screen"
    	Monitor    "Monitor[0]"
    	Identifier "Screen 1"
    	Device     "X1400"
    EndSection
    
    
    Section "DRI"
    	Mode         0666
    EndSection

  4. #14
    Join Date
    May 2007
    Posts
    352

    Default

    Show us your full /var/log/Xorg.0.log file and the full output of 'LIBGL_DEBUG=verbose glxinfo'

    Adam

  5. #15

  6. #16
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,795

    Default

    This looks problematic:

    "(II) RADEON(0): XAA Render acceleration unsupported on Radeon 9500/9700 and newer. Please use EXA instead."

    The default is EXA but for some reason the driver tries to use XAA. Try forcing EXA with:

    Code:
    Section "Device"
    	Identifier  "X1400"
    	Driver      "radeon"
    	Option      "AccelMethod" "EXA"
    EndSection

  7. #17
    Join Date
    May 2007
    Posts
    352

    Default

    I would not switch to EXA till you get direct rendering working. What is the output of 'dmesg | grep drm' and 'lsmod | grep drm'?

    Adam

  8. #18

    Default

    Code:
    lsmod | grep drm
    drm_kms_helper         17183  1 radeon
    drm                   107507  3 radeon,ttm,drm_kms_helper
    i2c_core               12612  4 radeon,drm,i2c_algo_bit,i2c_i801
    agpgart                19516  3 ttm,drm,intel_agp
    dmesg | grep drm

    Thanks all for your help! I'll get this to work...

  9. #19
    Join Date
    May 2007
    Posts
    352

    Default

    You need to install the Debian kernel firmware package. It's called firmware-linux.

    Then you need to unload and reload the radeon kernel module (or simply reboot). Once Direct Rendering is working, switch to the EXA AccelMethod per RealNC's instructions.

  10. #20
    Join Date
    Jun 2009
    Posts
    2,929

    Default

    Yes.

    Currently, neither 3d acceleration nor EXA is working. No wonder everything is slow.

    Both are supported on your chipset with your currently installed drivers, but you will need the firmware.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •