Results 1 to 2 of 2

Thread: Xorg freeze on startup

  1. #1
    Join Date
    Feb 2010
    Posts
    3

    Default Xorg freeze on startup

    Hello,
    Having a bit of a problem with booting up xorg with the open-source radeon driver both as a module and builtin into the kernel. Disabled the KMS thinking that it might be a problem but it still wont work. The KMS itself works "decently" (60s wait time before it starts up after booting, disabled it for now before xorg works again)

    From the xorg log it seems to go fine until it reaches the framebuffer part of the "bootup" and then the log stops and im assuming the system hangs then. I cant switch to a different VT and even after waiting a few minutes nothing moves.

    This sys used to run on fglrx but i removed it via the ati uninstall script and later checked if there are any files containing fgrlx left.

    running gentoo with
    vanilla-2.6.33-rc8
    xorg-server 1.6.5-r1

    the machine is a HP pavilion DV5 (1130-en on hp page) with HD3450 (dv620 chip?)

    Ive also tried using a new xorg.conf file by using "X -configure"

    Any help would be appreciated

  2. #2
    Join Date
    Feb 2010
    Posts
    3

    Default

    Sigh,
    If anyone can then you can remove this thread because I realized that I am a moron and forgot to reinstall libdrm.

    Sorry for the false alarm and more spam on the front page

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •