Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: How do I get underscan with radeonhd ???

  1. #1
    Join Date
    Feb 2010
    Posts
    19

    Default How do I get underscan with radeonhd ???

    Hi Folks,
    after my long fight with fglrx I found a way get radeonhd running on my system (with xv acceleration).
    But 1 Problem is still left.
    MY TV makes some overscan what is extremly annoying when you use the Desktop. There is DEFINITELY no way to turn the overscan off.
    So here's the big Question.
    How do I get a fitting Desktop on my TV (Panasonic TH-42PV60EH).
    Lets say I want to run 1280x720_50 but the visible Frame is only 1200x680.

    Is there any way (my be with Xrandr and virtual screensize) ????

  2. #2
    Join Date
    Jan 2009
    Posts
    117

    Default

    man xrandr
    /scale
    n
    q
    xrandr --output <tv> --scale 0.937x0.944

  3. #3
    Join Date
    Feb 2010
    Posts
    19

    Default

    I should admit, that xorg is a mystery to me.
    Sorry, but I can't find "--scale" in "man xrandr".
    Maybe I should tell you that I' using Debian Lenny which has Randr 1.2.
    In the Online Manpage of "xrandr" I saw the option. But it was for xrandr 1.3. Maybe it's not in 1.2 ?
    Is there probably another solution ?

  4. #4
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    Disable scaling in your tv settings or buy a better tv

  5. #5
    Join Date
    Feb 2010
    Posts
    19

    Default

    Hi Kano,

    funny thing is ... I'm using your Repo.
    Maybe you could backport Xorg. (hahaha )
    Joking aside. Is there no other way to get rid of this overscan ?
    I got this running with fglrx but there were enough other Problems (tearing or VDR with opengl and no OSD).

    So I need to change to SIDUX or similar ?

  6. #6
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    The OSD can be be easyly enabled with opengl, well some may call it tricky (because 2D_Tex_Fragprog does not work, the same for nvidia, no fglrx fault it seems):

    In ~/.xine/config

    Code:
    video.driver:opengl
    video.output.opengl_renderer:2D_Tex

  7. #7
    Join Date
    Feb 2010
    Posts
    19

    Default

    Thanks I'll try this.
    But I hoped to stay with the OSS drivers ;-(
    We'll see.
    Maybe next time I'm going to stress you right in your own forum ;-)

  8. #8
    Join Date
    Feb 2010
    Posts
    19

    Default

    Ok, OSD is working with the parameters you said.
    But fglrx stays (like always) unusable for videoapplications. There's always tearing. No matter what I adjust in ControlCenter.
    So I'm staying with radeonhd.
    So has ANYONE a hint howto "underscan"with a Xorg driver under Debian Lenny ?

  9. #9
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    You have to force vsync for opengl (quality mode).

  10. #10
    Join Date
    Dec 2007
    Posts
    2,329

    Default

    Quote Originally Posted by batesman View Post
    So has ANYONE a hint howto "underscan"with a Xorg driver under Debian Lenny ?
    You need a modeline with the timing adjusted to underscan.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •