Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Fglrx 10.2 fails to install on 2.6.33

  1. #1
    Join Date
    Jan 2010
    Posts
    26

    Default Fglrx 10.2 fails to install on 2.6.33

    Hey,

    did anone made it to install fglrx10.2 on the new kernel 2.6.33? I can build teh *.deb but when i try to install it throws an error: Kernel Version differs "" and "2.6.33" inside utsrelease.h (wich does not exists anymore)
    Can someone help?
    Cheers

  2. #2
    Join Date
    Oct 2008
    Posts
    62

    Default

    I have not tried it out myself, but there is a patch for 2.6.33:

    http://www.phoronix.com/forums/showp...4&postcount=10

  3. #3
    Join Date
    Apr 2007
    Location
    Hungary
    Posts
    84

  4. #4
    Join Date
    Jan 2010
    Posts
    26

    Default

    Thanks all!
    Will try this patch. Guess i have to extract the .run and apply it there?!

  5. #5
    Join Date
    Dec 2009
    Posts
    63

    Default

    After patching the files. How do i build and install the driver?

  6. #6
    Join Date
    Feb 2010
    Posts
    8

    Default

    Quote Originally Posted by Viper_Scull View Post
    After patching the files. How do i build and install the driver?
    Just type in the unpacked ati package :
    sh ati-installer.sh . --install

    Be attentive : between words ati-installer.sh and --install it`s a "." (point,dot etc).

  7. #7
    Join Date
    Mar 2010
    Posts
    7

    Default

    opening the .patch file, I haven't found references to 10.2. Instead it refers 10.1. Will this patch work for 10.2?

    If so, what's the correct procedure to do so?

    I tried:
    Code:
    gtl@cpc-5564:~/Downloads$ cd ati
    gtl@cpc-5564:~/Downloads/ati$ ls
    ati-driver-installer-10-2-x86.x86_64.run  fglrx-2.6.33.patch
    gtl@cpc-5564:~/Downloads/ati$ sh ati-driver-installer-10-2-x86.x86_64.run --extract .
    Warning: target directory exists .
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.702.............(...)
    gtl@cpc-5564:~/Downloads/ati$ patch -p0 fglrx-2.6.33.patch
    nothing else happens.

    Please avise,
    Thanks in advance,

    gtludwig

  8. #8
    Join Date
    Feb 2010
    Posts
    8

    Default

    Quote Originally Posted by gtludwig View Post
    opening the .patch file, I haven't found references to 10.2. Instead it refers 10.1. Will this patch work for 10.2?
    10.2 with patch & kernel 2.6.33 work perfectly.

    If so, what's the correct procedure to do so?
    how to patch it :
    cd unpacked_ati_directory
    patch -p1 < ../fglrx.2.6.33.patch
    sh ati-installer.sh . --install

    After successfully compiling restart your penguin
    If you had some errors like freeze,reboot or bug: "smp_processor preemptible" ( run terminal and type dmesg )recompile your kernel changing option from "preemptible kernel low latency desktop" to "Voluntary kernel preemption".
    Greetings.

  9. #9
    Join Date
    Feb 2010
    Posts
    32

    Default

    So if I don't see "smp_processor preemptible", I don't have to rebuild my kernel, right? (I ask because I'm getting annoying hangs sporadically with the driver.)

  10. #10
    Join Date
    Mar 2010
    Posts
    7

    Default

    I managed to apply the patch thanks to paproch, it installed ok, but X failed to start. Switching to radeonhd I can fire up X, properly.

    I'm wondering how can I completely remove this driver so i can perform a clean installation. I'll edit this post to paste the link for my /var/log/Xorg.0.log in a little while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •