Results 1 to 6 of 6

Thread: [RadeonHD] [drm-radeon-module-git-r6xx-r7xx-3d] Compilation issue

  1. #1
    Join Date
    Mar 2010
    Posts
    2

    Default [RadeonHD] [drm-radeon-module-git-r6xx-r7xx-3d] Compilation issue

    Hello all,

    I'm running under an archlinux 2.6.32 and I try to make my radeon HD 3650 run properly.

    The compilation of the drm-radeon-module-git-r6xx-r7xx-3d driver experimental return this:

    /var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core/drm_agpsupport.c: In function ‘drm_agp_bind_pages’:
    /var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core/drm_agpsupport.c:520: erreur: implicit declaration of function ‘phys_to_gart’
    /var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core/drm_agpsupport.c:520: attention : assignment makes pointer from integer without a cast
    /var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core/drm_agpsupport.c: In function ‘drm_agp_populate’:
    /var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core/drm_agpsupport.c:589: attention : assignment makes pointer from integer without a cast
    make[3]: *** [/var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core/drm_agpsupport.o] Erreur 1
    make[2]: *** [_module_/var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core] Erreur 2
    make[2]: quittant le répertoire « /usr/src/linux-2.6.32-ARCH »
    make[1]: *** [modules] Erreur 2
    make[1]: quittant le répertoire « /var/abs/local/yaourtbuild/drm-radeon-module-git-r6xx-r7xx-3d/src/drm-build/linux-core »
    make: *** [radeon.o] Erreur 2


    I search all around the web for some information but... i just know i'm not alone.

    thx for any help.


    PS: sorry for my english

  2. #2
    Join Date
    Dec 2007
    Posts
    2,395

    Default

    r6xx/r7xx 3D drm support has been available in the kernel since 2.6.32. My old r6xx-r7xx-3d drm branch should be considered long dead at this point.

  3. #3
    Join Date
    Oct 2008
    Posts
    52

    Default

    Quote Originally Posted by agd5f View Post
    r6xx/r7xx 3D drm support has been available in the kernel since 2.6.32. My old r6xx-r7xx-3d drm branch should be considered long dead at this point.
    Ups, that's my package. It should be deleted.

    Your card should work out of the box with arch (read the wiki).
    If you want some bleeding edge drivers, read this thread: http://bbs.archlinux.org/viewtopic.php?id=79509&p=1

  4. #4
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,798

    Default

    Why not delete the outdated git branches? Less confusion that way.

  5. #5
    Join Date
    Mar 2010
    Posts
    2

    Default

    Quote Originally Posted by agd5f View Post
    r6xx/r7xx 3D drm support has been available in the kernel since 2.6.32. My old r6xx-r7xx-3d drm branch should be considered long dead at this point.
    You mean, its not necessary to install the package ?

    Cause, when i do:

    glxinfo | grep render
    _____________________
    direct rendering: Yes
    OpenGL renderer string: Software Rasterizer

    So what ? i have to use radeonhd or radeon ?

    Thx 4 hlp.

  6. #6
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    Quote Originally Posted by RealNC View Post
    Why not delete the outdated git branches? Less confusion that way.
    General consensus is that the history is sometimes useful. The best idea I heard in earlier discussions was putting a "final commit" into each dead branch with an appropriately worded commit message.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •