Hey everyone, I just recently went through and managed to get a:

./phoronix-test-suite install all

working on a pretty un-molested Fedora 12 installation.

My F12 was installed just with the "development" option installed, and I installed the NVIDIA blob driver. Here are the steps I needed to take to get it going:

Code:
yum install php-cli qt3-devel nasm
The above are dependencies not fulfilled by any default Fedora 12 package groups.

encode-ape

I had to manually track down a copy of this software and put it in the download-cache, as the original link is broken. The link I used is here: http://dside.dyndns.org/files/darklin/ and the MD5 matched.

Then I had to apply the patch provided in this post here on the PTS forums. It fixes some casting issues to allow it to compile.

Then I tarred it back up, modified the MD5.

espeak

For this one I had to unzip the zip file and copy portaudio19.h to portaudio.h in src/. This allows it to build against portaudio v19, whereas it is packaged to default against v18. Fedora 12 ships with v19.

Code:
unzip espeak-1.40.02-source.zip
cp espeak-1.40.02-source/src/portaudio19.h espeak-1.40.02-source/src/portaudio.h
Zip it back up, modify the MD5.

fs_mark

I needed to change the Makefile for this guy, to disable the static compiling.

The CFLAGS= line changed to CFLAGS+= to not override the env CFLAGS, and I removed -static from the gcc call line.

Code:
change:
CFLAGS= -O2 -Wall -D_FILE_OFFSET_BITS=64
to:
CFLAGS+= -O2 -Wall -D_FILE_OFFSET_BITS=64

change:
${CC} -static -o fs_mark fs_mark.o lib_timing.o
to:
${CC} -o fs_mark fs_mark.o lib_timing.o
Tar it back up, modify the md5.

gnupg

For this one I had to apply this patch. It provides a GCC 4.3.0 fix for bit-fields.

Tar it back up, modify the md5.

n-queens

Modify version1.0/omp/Makefile to remove the static flag for compiling.

Code:
change:
gcc -static -Wall -O2 $(SRC) -o $(TRG)
to:
gcc -Wall -O2 $(SRC) -o $(TRG)
Tar it up, modify the md5.

nero2d

This one ships with two symlinks that are broken:
Code:
nero2d-2.0.2/doc/texinfo.tex
nero2d-2.0.2/doc/mdate-sh
They originally point to:
Code:
mdate-sh -> /usr/share/automake-1.10/mdate-sh
texinfo.tex -> /usr/share/automake-1.10/texinfo.tex
Update the links to point to the proper version of automake-1.11 that ships with Fedora 12:
Code:
mdate-sh -> /usr/share/automake-1.11/mdate-sh
texinfo.tex -> /usr/share/automake-1.11/texinfo.tex
Code:
rm nero2d-2.0.2/doc/texinfo.tex
rm nero2d-2.0.2/doc/mdate-sh
ln -s /usr/share/automake-1.11/textinfo.tex nero2d-2.0.2/doc/texinfo.tex
ln -s /usr/share/automake-1.11/mdate-sh nero2d-2.0.2/doc/mdate-sh
Tar it up, modify the MD5.

qgears2

This one just required an edit to the actual test-resource install script. The default one calls qmake, which points to QT3 on Fedora 12. That creates a qgears.pro file which will not have the proper settings. We need to get it to call qmake-qt4 instead.

Modify phoronix-test-suite/pts/test-resources/qgears2/install.sh

Code:
change (line 33):
qmake
to:
qmake-qt4
That's it for that one.

Hopefully this information is useful to someone. If someone needs my new MD5s/archives, let me know.