Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Linux 2.6.34-rc1 Kernel Is Out w/ New Features

  1. #11
    Join Date
    Jun 2008
    Location
    Italy
    Posts
    74

    Default

    Quote Originally Posted by Melcar View Post
    As far as PM, it does seem to work. The core is downclocking fine as far as I can tell, which is making things slower than usual; KMS makes 2D slow as is, so the downclocking is making things worse .
    Mobility 3470 here. The first DRM power management patches did just that, slowing 2D to unacceptable levels. Since 2.6.33 + patches, it's become very good, with no noticeable slowness at all. Now, it seems to change core and memory frequencies very fast.

    And my notebook stopped hanging with a black screen due to overheating, as well.

    Now, I'm just hoping the current power management, or the future advancements, will be enough to cope with the summer's heat.

    Thank you developers.

  2. #12
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,098

    Default

    On my laptop (200M) it works a bit better, in that it's not unbearably slow. Thing is that when the core downclocks, response becomes "jumpy"; the mouse cursor seems to get "stuck" as I move it across the screen, and window animations sometimes leave a noticeable trace behind them. This again, is due to KMS making things slow and the slower frequencies only worsening the problem. Should be better once I move to a newer xserver.

  3. #13
    Join Date
    May 2009
    Posts
    42

    Default

    Melcar: how did you enable PM ? I tried everything but I'm still on default clocks...

    I have integrated 3200 HD, may this be the problem? Is PM supposed to work with integrated cards?

  4. #14
    Join Date
    Dec 2007
    Location
    Merida
    Posts
    1,098

    Default

    From the grub2 menu, I just added:

    Code:
    radeon.dynpm=1
    ... to the kernel parameter line. It works on both my HD4850 and my laptop's integrated 200M.

  5. #15
    Join Date
    May 2009
    Posts
    42

    Default

    hm, with this I have
    Code:
    state: PM_STATE_ACTIVE
    , but engine clock is always on default value...

  6. #16
    Join Date
    Aug 2009
    Location
    south east
    Posts
    337

    Default The phoronix baseline test

    PHORONIX BASELINE TEST

    Have a series of test to check basic functionality.
    Suspend / Resume, Hibernate Same test really.<br>
    Acceleration<br>
    Sound<br>
    etc.<br>

    Manufacturers could begin testing before they release new hardware.

  7. #17
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,282

    Default

    Manufacturers do this already - isn't the issue that you want them to do it with *your* Linux distro rather than just with Windows ?

  8. #18
    Join Date
    Mar 2010
    Posts
    1

    Default

    I have:
    Code:
    state: PM_STATE_MINIMUM
    What does it mean? The new kernel dropped about 20C (from 80C to 60C) which is already very good result but I still have a hairdryer instead of fan (it's sooooooo annoying). Maybe with ACTIVE instead of MINIMUM it'll be better? Is there any way to change it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •