You need 2.4.16 or newer compiled with --enable-radeon-experimental-api to build libdrm_radeon for kms. As of 2.4.18, libdrm_radeon is enabled by default. libdrm and libdrm_radeon are not tied to a particular kernel. You can happily use the more recent libdrm* with older kernels.