Results 1 to 5 of 5

Thread: Problems installing fglrx 10.1 or 10.2 on Debian lenny

  1. #1
    Join Date
    Mar 2010
    Posts
    3

    Default Problems installing fglrx 10.1 or 10.2 on Debian lenny

    Hello!

    I'm new to Linux and to this forum, so, please, don't be so hard on me!

    I recently installed a Debian lenny linux on my PC, but I can't get my ATI Radeon HD 5770 to work, even using the radeon driver.
    I'm using the 2.6.26-2-686 kernel.

    So, I downloaded the fglrx 10.1 and 10.2 drivers, and managed to build the DEB packages, but when I try to install them, using the dpkg -i command, I get an error after the "Processing triggers for man-db" message, but I can't identify what went wrong. Get the same error trying to install either the 10.1or the 10.2.

    Does the installation generate some kind of log?
    Do you have any tips that could help me? Please?

    Thank you in advance!

  2. #2
    Join Date
    Mar 2010
    Posts
    3

    Default

    Hello again!

    Would someone please take a look? I tried to install the driver as follows (after downloading 10.1 again):

    daniel@lerdo-gti:~/ati$ ./ati-driver-installer-10-1-x86.x86_64.run --extract fglrx-10.1
    Creating directory fglrx-10.1
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.69.............................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ..................................
    daniel@lerdo-gti:~/ati$ cd fglrx-10.1/
    daniel@lerdo-gti:~/ati/fglrx-10.1$ cd packages
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages$ cd Debian
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian$ cd ati
    bash: cd: ati: No such file or directory
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian$ ls
    ati-packager.sh ChangeLog dists module
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian$ gedit ati-packager.sh
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian$ cd module
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian/module$ ls
    control.template dirs.template postinst rules
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian/module$ cd ..
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian$ cd dists
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian/dists$ cd lenny
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian/dists/lenny$ gedit fglrx-driver.shlibs
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian/dists/lenny$ cd ..
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian/dists$ cd ..
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages/Debian$ cd ..
    daniel@lerdo-gti:~/ati/fglrx-10.1/packages$ cd ..
    daniel@lerdo-gti:~/ati/fglrx-10.1$ ls
    arch fglrx-uninstall.sh pre_km.sh
    ati-installer.sh installer_creation_policy preun_drv.sh
    ATI_LICENSE.TXT lokixml.sh preun_km.sh
    ati-packager-helper.sh map_xname.sh README.distro
    ati-packager-wrapper.sh packages setup.data
    automatic-install.exp post_drv.sh verify_install.sh
    check.sh post_km.sh x680
    common postun_cp.sh x680_64a
    component_config.sh postun_drv.sh x690
    config_install.sh postun_km.sh x690_64a
    copy_uninstall_files.sh postun_rn.sh x740
    create_log.sh pre_cp.sh x740_64a
    default_policy.sh pre_drv.sh
    daniel@lerdo-gti:~/ati/fglrx-10.1$ cp arch/x86/usr/lib/libatiuki.so.1.0 x690/usr/X11R6/lib/
    daniel@lerdo-gti:~/ati/fglrx-10.1$ ln -s libatiuki.so.1.0 x690/usr/X11R6/lib/libatiuki.so.1
    daniel@lerdo-gti:~/ati/fglrx-10.1$ ./ati-installer.sh 10.1 --buildpkg Debian/lenny
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Debian/lenny
    Package build failed!
    Package build utility output:
    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CPPFLAGS to default value:
    dpkg-buildpackage: set LDFLAGS to default value:
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    dpkg-buildpackage: source package fglrx-installer
    dpkg-buildpackage: source version 8.69-1
    dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
    debian/rules build
    dpkg-buildpackage: host architecture i386
    dh_testdir
    # move licenses away from binary dir
    if [ ! -d usr/share/doc/fglrx ]; then \
    mkdir -p usr/share/doc/fglrx; \
    mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
    fi
    # set executable on user apps
    find usr/X11R6/bin -type f | xargs chmod a+x
    # remove exec bit from files that don't deserve it
    find usr/X11R6/include \
    usr/X11R6/lib \
    usr/X11R6/lib64 \
    usr/share usr/src -type f | xargs chmod -x
    find: `usr/X11R6/lib64': No such file or directory
    find lib -not -name "*.sh" -type f | xargs chmod -x
    find lib -name "*.sh" -type f | xargs chmod +x
    # set proper permissions on /etc files
    if [ -d etc/ati ]; then \
    chmod 755 etc/ati ; \
    chmod 644 etc/ati/* ; \
    chmod a+x etc/ati/*.sh ; \
    fi
    if [ -f debian/fglrx.default ]; then \
    mv -v debian/fglrx.default debian/fglrx; \
    fi
    `debian/fglrx.default' -> `debian/fglrx'
    fakeroot debian/rules binary
    dh_testdir
    # move licenses away from binary dir
    if [ ! -d usr/share/doc/fglrx ]; then \
    mkdir -p usr/share/doc/fglrx; \
    mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
    fi
    # set executable on user apps
    find usr/X11R6/bin -type f | xargs chmod a+x
    # remove exec bit from files that don't deserve it
    find usr/X11R6/include \
    usr/X11R6/lib \
    usr/X11R6/lib64 \
    usr/share usr/src -type f | xargs chmod -x
    find: `usr/X11R6/lib64': No such file or directory
    find lib -not -name "*.sh" -type f | xargs chmod -x
    find lib -name "*.sh" -type f | xargs chmod +x
    # set proper permissions on /etc files
    if [ -d etc/ati ]; then \
    chmod 755 etc/ati ; \
    chmod 644 etc/ati/* ; \
    chmod a+x etc/ati/*.sh ; \
    fi
    if [ -f debian/fglrx.default ]; then \
    mv -v debian/fglrx.default debian/fglrx; \
    fi
    dh_testdir
    dh_testroot
    dh_clean -k
    dh_installdirs
    # Create the directories to install into
    dh_installdirs -pfglrx-driver \
    usr \
    usr/lib/xorg \
    usr/lib/xorg/modules \
    usr/lib/dri \
    usr/bin \
    usr/sbin \
    etc/acpi \
    etc/acpi/events \
    etc/default \
    etc/X11/Xsession.d
    dh_installdirs -pfglrx-driver-dev \
    usr \
    usr/include \
    usr/lib
    dh_installdirs -pfglrx-kernel-src \
    usr/src/modules/fglrx \
    usr/src/modules/fglrx/debian
    dh_installdirs -A -pfglrx-amdcccle \
    usr \
    usr/bin \
    usr/share \
    usr/share/applnk \
    usr/share/applications \
    usr/share/icons \
    usr/share/pixmaps
    dh_installdirs -p \
    usr/src
    dh_install
    ldconfig -n usr/X11R6/lib/
    make: ldconfig: Command not found
    make: *** [binary] Error 127
    dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2
    daniel@lerdo-gti:~/ati/fglrx-10.1$ sudo ./ati-installer.sh 10.1 --buildpkg Debian/lenny
    ==================================================
    ATI Technologies Linux Driver Installer/Packager
    ==================================================
    Generating package: Debian/lenny
    Package /home/daniel/ati/fglrx-driver_8.69-1_i386.deb has been successfully generated
    Package /home/daniel/ati/fglrx-driver-dev_8.69-1_i386.deb has been successfully generated
    Package /home/daniel/ati/fglrx-kernel-src_8.69-1_i386.deb has been successfully generated
    Package /home/daniel/ati/fglrx-amdcccle_8.69-1_i386.deb has been successfully generated
    daniel@lerdo-gti:~/ati/fglrx-10.1$ ls
    arch fglrx-uninstall.sh pre_km.sh
    ati-installer.sh installer_creation_policy preun_drv.sh
    ATI_LICENSE.TXT lokixml.sh preun_km.sh
    ati-packager-helper.sh map_xname.sh README.distro
    ati-packager-wrapper.sh packages setup.data
    automatic-install.exp post_drv.sh verify_install.sh
    check.sh post_km.sh x680
    common postun_cp.sh x680_64a
    component_config.sh postun_drv.sh x690
    config_install.sh postun_km.sh x690_64a
    copy_uninstall_files.sh postun_rn.sh x740
    create_log.sh pre_cp.sh x740_64a
    default_policy.sh pre_drv.sh
    daniel@lerdo-gti:~/ati/fglrx-10.1$ cd ..
    daniel@lerdo-gti:~/ati$ ls
    ati-driver-installer-10-1-x86.x86_64.run fglrx-driver-dev_8.69-1_i386.deb
    fglrx-10.1 fglrx-installer_8.69-1_i386.changes
    fglrx-amdcccle_8.69-1_i386.deb fglrx-kernel-src_8.69-1_i386.deb
    fglrx-driver_8.69-1_i386.deb
    daniel@lerdo-gti:~/ati$ sudo dpkg -i fglrx-driver_8.69-1_i386.deb
    (Reading database ... 107487 files and directories currently installed.)
    Unpacking fglrx-driver (from fglrx-driver_8.69-1_i386.deb) ...
    Adding `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-driver'
    Adding `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.so.1 by fglrx-driver'
    Adding `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/diversions/libdri.so by fglrx-driver'
    dpkg: error processing fglrx-driver_8.69-1_i386.deb (--install):
    trying to overwrite `/usr/lib/xorg/modules/extensions/libglx.so', which is also in package xserver-xorg-core
    dpkg-deb: subprocess paste killed by signal (Broken pipe)
    Removing `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.so.1 by fglrx-driver'
    Removing `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-driver'
    rmdir: failed to remove `/usr/lib/fglrx/diversions': Directory not empty
    rmdir: failed to remove `/usr/lib/fglrx': Directory not empty
    Removing `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/diversions/libdri.so by fglrx-driver'
    Processing triggers for man-db ...
    Errors were encountered while processing:
    fglrx-driver_8.69-1_i386.deb

  3. #3
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    209

    Default

    Try with only,
    daniel@lerdo-gti:~/ati$ ./ati-driver-installer-10-1-x86.x86_64.run

  4. #4
    Join Date
    Mar 2010
    Posts
    3

    Default

    Quote Originally Posted by storma View Post
    Try with only,
    daniel@lerdo-gti:~/ati$ ./ati-driver-installer-10-1-x86.x86_64.run
    The thing is when I first tried to install the driver, I couldn't start gdm, the screen flickered and and error message was shown, so I was trying to install via console, text-mode only.
    After a long battle I could start gdm using a "1152 x 864" resolution, but after that I didn't even bother to try the automated installer.
    I tried now, and guess what? It worked. So I'm deeply grateful to you, and I'm feeling quite lame right now.

    Thank you again!


    Regards

  5. #5
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    209

    Default

    No worries, I got frustrated by the same thing a while back.

    You can also use the same command without X running.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •