Phoronix: More Backporting Madness: X Server 1.8 To 1.7

With Ubuntu 10.04 LTS shipping with the Linux 2.6.32 kernel rather than the latest stable release (the Linux 2.6.33 kernel), there has been some back-porting of code to this older release. The Lucid Lynx is using the 2.6.32 kernel since this is a Long-Term Support release and so Canonical and the Ubuntu kernel team has been more conservative this time around...

http://www.phoronix.com/vr.php?view=ODA5OA