Page 2 of 10 FirstFirst 1234 ... LastLast
Results 11 to 20 of 100

Thread: Woah, AMD Releases OpenGL 4.0 Linux Support!

  1. #11
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    Just that you can not use the driver with Xserver 1.7, they should have used a newer base.

  2. #12
    Join Date
    Aug 2009
    Posts
    2,264

    Default

    Correction thanks to the awesome time limite Phoronix!
    -EyeFinity (which no one but a single rich nerd without a life will ever use )

  3. #13
    Join Date
    Oct 2009
    Posts
    2,110

    Default

    A *very* quick glance suggests that this *does* support xserver1.7....

    Code:
    if [ "$xorg_server_ver_num" ]
                then
                    if [ `echo "$xorg_server_ver_num" | grep -c '1\.7'` -gt 0 ]
                    then                    
                        X_VERSION="Xorg"
                        x_ver_num="7.5"
                    elif [ `echo "$xorg_server_ver_num" | grep -c '1\.6'` -gt 0 ]
                    then                    
                        X_VERSION="Xorg"
                        x_ver_num="7.4"
                    elif [ `echo "$xorg_server_ver_num" | grep -c '1\.5'` -gt 0 ]
                    then                   
                        X_VERSION="Xorg"
                        x_ver_num="7.4"
                    elif [ `echo "$xorg_server_ver_num" | grep -c '^1\.4'` -gt 0 ]
                    then
                        X_VERSION="Xorg"
                        x_ver_num="7.3"
                    fi
                fi
    
    
                if [ "${x_name}" = "Xorg" -a ${x_maj} -eq 7 -a ${x_min} -eq 5 ]; then
            		x_ver_internal=x740
                # Map Xorg 7.4
                elif [ "${x_name}" = "Xorg" -a ${x_maj} -eq 7 -a ${x_min} -eq 4 ]; then
       		        x_ver_internal=x740
                else
                    # Workaround to set internal version number (for platform binary
                    # directory) to handle modular X
                    if [ ${x_maj} -lt 4 -o ${x_maj} -ge 7 ]; then
                            x_ver_internal=x690
                    fi
                fi

  4. #14
    Join Date
    May 2008
    Posts
    45

    Default

    Why can't they do this with the Ubuntu Beta drivers? It proves that they can release unsupported drivers... well maybe they will start supporting the latest Xorg before it is released.

  5. #15
    Join Date
    Aug 2007
    Posts
    6,631

    Default

    @droidhacker

    Do you see a x750 dir? I don't, but feel free to try it.

  6. #16
    Join Date
    Oct 2009
    Posts
    2,110

    Default

    Quote Originally Posted by Kano View Post
    @droidhacker

    Do you see a x750 dir? I don't, but feel free to try it.
    No, but it very specifically sets it to use x740 when 7.5 is detected. Now why would they bother with that unless the x740 files were rigged to work with 7.5?

  7. #17
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,791

    Default

    Quote Originally Posted by droidhacker View Post
    No, but it very specifically sets it to use x740 when 7.5 is detected. Now why would they bother with that unless the x740 files were rigged to work with 7.5?
    That was always the case in previous versions too.

  8. #18
    Join Date
    Jan 2010
    Posts
    159

    Default

    Quote Originally Posted by V!NCENT View Post
    -EyeFinity (which no one but a single rich nerd without a life will ever use )
    Don't say that! I once had 3 Displays connected to my computer .....

    As a matter of fact two of my old CRT's died since then, but there will come a time when I once again own more than 2 functioning displays and then I will be Very Thankful to AMD for this feature.


    @ Dirver: Well done. Nice seeing AMD catch up on the diver side.

  9. #19
    Join Date
    Oct 2007
    Location
    Poland
    Posts
    197

    Default

    Hard to believe go ATI go

  10. #20
    Join Date
    Oct 2007
    Location
    Hannover (Germany)
    Posts
    125

    Default

    Does anyone knows the code for the /etc/ati/signature file, to remove the watermark?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •