Page 3 of 10 FirstFirst 12345 ... LastLast
Results 21 to 30 of 100

Thread: Woah, AMD Releases OpenGL 4.0 Linux Support!

  1. #21
    Join Date
    Sep 2006
    Location
    PL
    Posts
    910

    Default

    am i the only one that feels that opengl version race will soon take off?

    jumping ahead to 4.0, while 3.x hasn't been that long around. i guess we'll see 5.0 pretty soon just because they feel like it.

  2. #22
    Join Date
    Sep 2008
    Location
    Netherlands
    Posts
    510

    Default

    OpenGL 4.0 introduces features in the core API that don't work on older hardware. OpenGL 3.4 was introduced on the same day as 4.0, and introduces all 4.0 features that still work on older hardware.

    You can be sure that OpenGL 5.0 will come out as soon as NVIDIA and AMD decide we all need to buy new hardware.

  3. #23
    Join Date
    Sep 2008
    Location
    Netherlands
    Posts
    510

    Default

    Fake Edit: That would be OpenGL 3.3, not 3.4.

  4. #24
    Join Date
    Oct 2007
    Posts
    912

    Default

    Considering the involvement of AMD in the OpenGL 4.0 spec (just looking through the OpenGL registry shows it) it's not surprising they have internal builds running 4.0, but it's very welcome to see it released.
    Go AMD.

  5. #25
    Join Date
    Dec 2008
    Location
    Creve Coeur, Missouri
    Posts
    397

    Default Notable performance improvement in Unigine

    With this new driver release, my score for Unigine went from 335 to 369. I am wondering if this performance improvement is around the board.

  6. #26
    Join Date
    Aug 2007
    Posts
    6,630

    Default

    My script installs it now

    http://kanotix.com/files/install-fglrx-debian.sh

    It took me an extra h to figure out what goes wrong with the Ubuntu packageing. I really hate when i have to correct those errors myself. 10-3 was simple, but that is unneeded extra time. When i would get ati hardware for every h i need to spend debugging what goes wrong my room would have been completely filled i guess...

  7. #27
    Join Date
    Dec 2009
    Posts
    49

    Default

    This driver doesnt work on my arch64, xorg-server 1.7.6, kernel 2.6.34-rc2. Although ubuntu's 10.4 beta works perfect.

    And i dont think its because fresh kernel, i have tested even older catalyst releases on with success. Must be xserver.
    Its working fine on my other testing system with arch i686 and xserver 1.6.x.

    Use this to disable testing watermark:

    echo 'd86529c71a19f73bcb899faf02ef234a:e04b1ef62834c60b fbbaaf9d60c21373ee5c11f25934b66f82a9aa9b32dc1772:b d551da52b7c910df9b1ac9b61d91328be074ba67b7fce5ffdb 9fc9d33dc1479bd001ca42b289109feb0ac9b60d9152ce0574 8fe7b78ce59f8bbfbcc33d81478' > /etc/ati/signature

  8. #28
    Join Date
    Dec 2008
    Posts
    988

    Default

    Quote Originally Posted by droidhacker View Post
    No, but it very specifically sets it to use x740 when 7.5 is detected. Now why would they bother with that unless the x740 files were rigged to work with 7.5?
    FYI Just tried it, doesn't work. You gotta love closed source

    Code:
    dlopen: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so: undefined symbol: DPMSEnabledSwitch
    (EE) Failed to load /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so

  9. #29
    Join Date
    Jul 2008
    Location
    Germany
    Posts
    677

    Default

    Quote Originally Posted by brouhaha View Post
    As I understand it, AMD's plan is to release 1.7 compatible drivers as soon as all of the major distributions have upgraded to 1.8.
    Than you understand it wrong. AMD has an List of Supported Distribution. Ubuntu is the first that start to ship the X-Server 1.7 with 10.04 and AMD release for Ubuntu an beta Driver. And i bet in 06.2010 or 07.2010 we see 1.7 Support in the "Normal" CCC Release.

  10. #30
    Join Date
    Oct 2007
    Location
    Hannover (Germany)
    Posts
    125

    Default

    Quote Originally Posted by LinuxID10T View Post
    With this new driver release, my score for Unigine went from 335 to 369. I am wondering if this performance improvement is around the board.
    I notice some little performance boost in HeroesOfNewerth. With the 10-2 driver and before, I got little lags. But with this driver, everything runs very smoothly.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •