Results 1 to 3 of 3

Thread: Do I need to replace libglx.so?

  1. #1
    Join Date
    Dec 2009
    Posts
    11

    Default Do I need to replace libglx.so?

    Hello, I tried without success to install the last proprietary beta drivers of ATI.

    Now, backing to the opensource xf86-video-ati drivers (I'm using the last git commit), I don't have 3D, and I guess this is the problem from Xorg.0.Log:

    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.4.0, module version = 1.0.0
    (II) Loading extension GLX


    I'm using Debian/Testing with a X1300 Mobility Radeon, and the glxinfo output is:

    name of display: :0.0
    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 135 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 15
    Current serial number in output stream: 15


    How can I solve this? I don't have a clue of how replacing libglx.so if I'm right and this is the problem.

    Thanks in advance.

  2. #2
    Join Date
    Jan 2009
    Posts
    86

    Default

    Could be a version mismatch. I understand the new catalyst drivers don't support xserver 1.7?

  3. #3
    Join Date
    Dec 2009
    Posts
    11

    Default

    Solved:

    Sorry for this post, I just reinstalled xserver-xorg-core (I didn't know where was the libglx.so until I've googled a little bit more) and everything is fine again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •