Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Ubuntu 10.04 + fglrx = seg fault

  1. #1
    Join Date
    Oct 2007
    Posts
    91

    Default Ubuntu 10.04 + fglrx = seg fault

    On a fresh install of Ubuntu 10.04 beta1 with fglrx installed via jockey on a Radeon HD 4290 (890GX Chipset), I get a seg fault when X starts. KMS is now enabled by default in Ubuntu, so I tried adding radeon.modeset=0 to the kernel parameters to see if that would help... nope.

    The OSS driver looks good, but the 3d support isn't quite there yet, so I still need fglrx. Any ideas?


    Xorg log will follow

  2. #2
    Join Date
    Oct 2007
    Posts
    91

    Default

    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-23-server x86_64 Ubuntu
    Current Operating System: Linux whitney 2.6.32-19-generic #28-Ubuntu SMP Thu Apr 1 10:39:41 UTC 2010 x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-19-generic root=UUID=04a74c47-f7db-45ce-a368-1396a39dc4a5 ro radeon.modeset=0 quiet splash
    Build Date: 30 March 2010 10:29:28PM
    xorg-server 2:1.7.6-2ubuntu1 (Timo Aaltonen <tjaalton@ubuntu.com>)
    Current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.1.log", Time: Fri Apr 2 13:11:14 2010
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d"
    (==) No Layout section. Using the first Screen section.
    (**) |-->Screen "Default Screen" (0)
    (**) | |-->Monitor "<default monitor>"
    (==) No device specified for screen "Default Screen".
    Using the first device section listed.
    (**) | |-->Device "Default Device"
    (==) No monitor specified for screen "Default Screen".
    Using a default monitor configuration.
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
    (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
    (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    (II) Loader magic: 0x7ca300
    (II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
    (--) using VT number 8
    (--) PCI:*(0:1:5:0) 1002:9714:1002:0000 ATI Technologies Inc rev 0, Mem @ 0xd0000000/268435456, 0xfe5f0000/65536, 0xfe400000/1048576, I/O @ 0x0000b000/256
    (--) PCI: (0:2:0:0) 14f1:8852:18ac:d618 Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder rev 2, Mem @ 0xfe600000/2097152
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) "extmod" will be loaded by default.
    (II) "dbe" will be loaded by default.
    (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    (II) "record" will be loaded by default.
    (II) "dri" will be loaded by default.
    (II) "dri2" will be loaded by default.
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/extra-modules/modules/extensions/libglx.so
    (II) Module glx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.5.0, module version = 1.0.0
    (II) Loading extension GLX
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.72.10
    Module class: X.Org Video Driver
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.72.10
    (II) ATI Proprietary Linux Driver Version Identifier:8.72.10
    (II) ATI Proprietary Linux Driver Release Identifier: 8.72.1
    (II) ATI Proprietary Linux Driver Build Date: Mar 10 2010 23:41:33
    (II) Primary Device is: PCI 01@00:05:0
    (WW) Falling back to old probe method for fglrx
    (II) PCS database file /etc/ati/amdpcsdb not found
    (II) Creating PCS database from initial defaults instead
    (--) Assigning device section with no busID to primary device
    (--) Chipset Supported AMD Graphics Processor (0x9714) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:1) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:5:1) found
    (II) AMD Video driver is running on a device generally supported by this driver
    (II) AMD Video driver is signed
    (II) fglrx(0): pEnt->device->identifier=0xfd7230
    (II) fglrx(0): === [atiddxPreInit] === begin
    (II) Loading sub module "vgahw"
    (II) LoadModule: "vgahw"
    (II) Loading /usr/lib/xorg/modules/libvgahw.so
    (II) Module vgahw: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 0.1.0
    ABI class: X.Org Video Driver, version 6.0
    (II) fglrx(0): Creating default Display subsection in Screen section
    "Default Screen" for depth/fbbpp 24/32
    (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
    (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    (==) fglrx(0): Default visual is TrueColor
    (==) fglrx(0): RGB weight 888
    (II) fglrx(0): Using 8 bits per RGB
    (==) fglrx(0): Buffer Tiling is ON
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Reloading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
    ukiDynamicMajor: found major device number 250
    ukiDynamicMajor: found major device number 250
    ukiOpenByBusid: Searching for BusID PCI:1:5:0
    ukiOpenDevice: node name is /dev/ati/card0
    ukiOpenDevice: open result is 11, (OK)
    ukiOpenByBusid: ukiOpenMinor returns 11
    ukiOpenByBusid: ukiGetBusid reports PCI:1:5:0
    (--) fglrx(0): Chipset: "ATI Radeon HD 4290" (Chipset = 0x9714)
    (--) fglrx(0): (PciSubVendor = 0x1002, PciSubDevice = 0x0000)
    (==) fglrx(0): board vendor info: original ATI graphics adapter
    (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
    (--) fglrx(0): MMIO registers at 0xfe5f0000
    (--) fglrx(0): I/O port at 0x0000b000
    (==) fglrx(0): ROM-BIOS at 0x000c0000
    (II) fglrx(0): AC Adapter is used

    Backtrace:
    0: /usr/bin/X (xorg_backtrace+0x28) [0x4a3248]
    1: /usr/bin/X (0x400000+0x655ad) [0x4655ad]
    2: /lib/libpthread.so.0 (0x7f17419e0000+0xf8f0) [0x7f17419ef8f0]
    3: /usr/bin/X (xf86findOption+0x20) [0x482590]
    4: /usr/bin/X (xf86findOptionValue+0x9) [0x4825b9]
    5: /usr/bin/X (0x400000+0x70abd) [0x470abd]
    6: /usr/bin/X (xf86ProcessOptions+0x2e) [0x470f9e]
    7: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86HandleInt10Options+0x80) [0x7f173e9ddc60]
    8: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86ExtendedInitInt10+0x37) [0x7f173e9cc377]
    9: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86InitInt10+0xb) [0x7f173e9cbedb]
    10: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7f173e3ba000+0x26e587) [0x7f173e628587]
    11: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7f173e3ba000+0x2739b3) [0x7f173e62d9b3]
    12: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (atiddxPreInit+0x51e) [0x7f173e628d9e]
    13: /usr/bin/X (InitOutput+0x552) [0x4739b2]
    14: /usr/bin/X (0x400000+0x26005) [0x426005]
    15: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7f17406d8c4d]
    16: /usr/bin/X (0x400000+0x25d59) [0x425d59]
    Segmentation fault at address 0x37

    Caught signal 11 (Segmentation fault). Server aborting

  3. #3
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    I get the same:

    5850:

    http://pastebin.com/16jHJwuK

    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-23-server x86_64 Ubuntu
    Current Operating System: Linux lupus 2.6.32-19-generic #28-Ubuntu SMP Thu Apr 1 10:39:41 UTC 2010 x86_64
    Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-19-generic root=/dev/mapper/sdc5_crypt ro quiet splash
    Build Date: 30 March 2010 10:29:28PM
    xorg-server 2:1.7.6-2ubuntu1 (Timo Aaltonen <tjaalton@ubuntu.com>)
    Current version of pixman: 0.16.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 5 02:44:49 2010
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d"
    (==) No Layout section. Using the first Screen section.
    (**) |-->Screen "Default Screen" (0)
    (**) | |-->Monitor "<default monitor>"
    (==) No device specified for screen "Default Screen".
    Using the first device section listed.
    (**) | |-->Device "Default Device"
    (==) No monitor specified for screen "Default Screen".
    Using a default monitor configuration.
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    Entry deleted from font path.
    (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    built-ins
    (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    (II) Loader magic: 0x7ca300
    (II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
    (++) using VT number 7

    (--) PCI:*(0:1:0:0) 1002:6899:1002:0b00 ATI Technologies Inc Cypress [Radeon HD 5800 Series] rev 0, Mem @ 0xd0000000/268435456, 0xfbde0000/131072, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) "extmod" will be loaded by default.
    (II) "dbe" will be loaded by default.
    (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
    (II) "record" will be loaded by default.
    (II) "dri" will be loaded by default.
    (II) "dri2" will be loaded by default.
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/extra-modules/modules/extensions/libglx.so
    (II) Module glx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.5.0, module version = 1.0.0
    (II) Loading extension GLX
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.72.10
    Module class: X.Org Video Driver
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Loading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.72.10
    (II) ATI Proprietary Linux Driver Version Identifier:8.72.10
    (II) ATI Proprietary Linux Driver Release Identifier: 8.72.1
    (II) ATI Proprietary Linux Driver Build Date: Mar 10 2010 23:41:33
    (II) Primary Device is: PCI 01@00:00:0
    (WW) Falling back to old probe method for fglrx
    (II) PCS database file /etc/ati/amdpcsdb not found
    (II) Creating PCS database from initial defaults instead
    (--) Assigning device section with no busID to primary device
    (--) Chipset Supported AMD Graphics Processor (0x6899) found
    (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
    (II) AMD Video driver is running on a device belonging to a group targeted for this release
    (II) AMD Video driver is signed
    (II) fglrx(0): pEnt->device->identifier=0x12a71a0
    (II) fglrx(0): === [atiddxPreInit] === begin
    (II) Loading sub module "vgahw"
    (II) LoadModule: "vgahw"
    (II) Loading /usr/lib/xorg/modules/libvgahw.so
    (II) Module vgahw: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 0.1.0
    ABI class: X.Org Video Driver, version 6.0
    (II) fglrx(0): Creating default Display subsection in Screen section
    "Default Screen" for depth/fbbpp 24/32
    (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
    (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    (==) fglrx(0): Default visual is TrueColor
    (==) fglrx(0): RGB weight 888
    (II) fglrx(0): Using 8 bits per RGB
    (==) fglrx(0): Buffer Tiling is ON
    (II) Loading sub module "fglrxdrm"
    (II) LoadModule: "fglrxdrm"
    (II) Reloading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
    ukiDynamicMajor: found major device number 250
    ukiDynamicMajor: found major device number 250
    ukiOpenByBusid: Searching for BusID PCI:1:0:0
    ukiOpenDevice: node name is /dev/ati/card0
    ukiOpenDevice: open result is 11, (OK)
    ukiOpenByBusid: ukiOpenMinor returns 11
    ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
    (--) fglrx(0): Chipset: "ATI Radeon HD 5800 Series " (Chipset = 0x6899)
    (--) fglrx(0): (PciSubVendor = 0x1002, PciSubDevice = 0x0b00)
    (==) fglrx(0): board vendor info: original ATI graphics adapter
    (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
    (--) fglrx(0): MMIO registers at 0xfbde0000
    (--) fglrx(0): I/O port at 0x0000c000
    (==) fglrx(0): ROM-BIOS at 0x000c0000
    (II) fglrx(0): AC Adapter is used

    Backtrace:
    0: /usr/bin/X (xorg_backtrace+0x28) [0x4a3248]
    1: /usr/bin/X (0x400000+0x655ad) [0x4655ad]
    2: /lib/libpthread.so.0 (0x7fa58af76000+0xf8f0) [0x7fa58af858f0]
    3: /usr/bin/X (xf86nameCompare+0x19) [0x483509]
    4: /usr/bin/X (xf86findOption+0x2c) [0x48259c]
    5: /usr/bin/X (xf86findOptionValue+0x9) [0x4825b9]
    6: /usr/bin/X (0x400000+0x70abd) [0x470abd]
    7: /usr/bin/X (xf86ProcessOptions+0x2e) [0x470f9e]
    8: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86HandleInt10Options+0x80) [0x7fa587f73c60]
    9: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86ExtendedInitInt10+0x37) [0x7fa587f62377]
    10: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86InitInt10+0xb) [0x7fa587f61edb]
    11: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7fa587950000+0x26e587) [0x7fa587bbe587]
    12: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7fa587950000+0x2739b3) [0x7fa587bc39b3]
    13: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (atiddxPreInit+0x51e) [0x7fa587bbed9e]
    14: /usr/bin/X (InitOutput+0x552) [0x4739b2]
    15: /usr/bin/X (0x400000+0x26005) [0x426005]
    16: /lib/libc.so.6 (__libc_start_main+0xfd) [0x7fa589c6ec4d]
    17: /usr/bin/X (0x400000+0x25d59) [0x425d59]
    Segmentation fault at address 0x352e32

    Caught signal 11 (Segmentation fault). Server aborting

    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.

    ddxSigGiveUp: Closing log
    that's not the only info:

    in the other log it says something

    along MTRR ... ioctl error


    strange is:

    I THINK I got the same error on my gentoo system with xorg-server 1.6.5 which wouldn't show me a desktop or window manager but works with xorg-server 1.7.5 and displays everything except stuff that is dependent on libGl.so. ...


    I'll see if I can note down the exact message - I believe that's the cause of fglrx not being able to run xorg and letting segfault X

    perhaps someone else could look through their logs and post it as well ?

    so we can nail it down ASAP and the fine devs @AMD could release a working driver

  4. #4
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    well, after the restart the driver seems to load fine and shows the already mentioned behavior I get under my gentoo-system & xorg-server 1.7.5

    so unfortunately I can't post the exact error-message involving mtrr


    X loads fine now but everything accelerated doesn't work and now also leads to segfaults:

    dmesg | grep err
    [ 0.000000] ACPI: IRQ0 used by override.
    [ 0.000000] ACPI: IRQ2 used by override.
    [ 0.000000] ACPI: IRQ9 used by override.
    [ 1.558752] ACPI: Using IOAPIC for interrupt routing
    [ 1.579669] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
    [ 1.579826] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR1E._PRT]
    [ 1.579889] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR20._PRT]
    [ 1.579935] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR21._PRT]
    [ 1.579991] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR22._PRT]
    [ 1.580036] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR23._PRT]
    [ 1.580081] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.BR24._PRT]
    [ 1.596732] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 6 7 *10 11 12 14 15)
    [ 1.596834] ACPI: PCI Interrupt Link [LNKB] (IRQs *5)
    [ 1.596931] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 6 7 10 *11 12 14 15)
    [ 1.597031] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 6 7 10 11 12 14 *15)
    [ 1.597131] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 6 7 10 11 12 *14 15)
    [ 1.597230] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 6 7 10 11 12 14 15) *0, disabled.
    [ 1.597330] ACPI: PCI Interrupt Link [LNKG] (IRQs *3 4 6 7 10 11 12 14 15)
    [ 1.597430] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 6 *7 10 11 12 14 15)
    [ 3.446858] generic-usb: probe of 0003:0BDA:0182.0005 failed with error -22
    [ 108.567656] glxinfo[2331]: segfault at 4 ip 00007f7d7c00911e sp 00007fff1661a8f0 error 4 in libGL.so.1.2[7f7d7bfb3000+a2000]
    [ 122.168426] fglrxinfo[2337]: segfault at 4 ip 00007f5b527cf11e sp 00007ffff631c580 error 4 in libGL.so.1.2[7f5b52779000+a2000]
    and here is the strace from fglrxinfo:

    http://pastebin.com/qRHA5pfn

    I dunno if it's useful, hopefully it is

  5. #5
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    the strange thing is that afaik under my gentoo-system & fglrxinfo it at least shows the name of the card 5850 and the "compatibility profile"

    the error message is also different (error 7)

    but I'm sure Ubuntu's fixing currently is more important and as a side-effect it'll also be able to work correctly on my gentoo-system again


    GO GO GO !

  6. #6
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    at bugs.launchpad.net I'm appending my bugs under the nickname dalinuxlova (discarding might delete useful data) to the existing bug:

    https://bugs.launchpad.net/ubuntu/+s...er/+bug/554057

  7. #7
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    interesting:

    the approach in the posted launchpad-bug worked !

    remove any existing /etc/X11/xorg.conf (if at all) and

    aticonfig --initial

    should create the basic layout xorg.conf

    after that compositing & X works flawlessly (at least on 10.04 amd64 here) for me:

    glxinfo
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: ATI
    server glx version string: 1.4
    server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
    client glx vendor string: ATI
    client glx version string: 1.4
    client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_NV_swap_group,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier, GLX_SGIX_swap_group,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap,
    GLX_EXT_framebuffer_sRGB, GLX_ARB_fbconfig_float
    GLX version: 1.4
    GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_swap_control,
    GLX_NV_swap_group, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier,
    GLX_SGIX_swap_group, GLX_SGIX_visual_select_group,
    GLX_EXT_texture_from_pixmap
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 5800 Series
    OpenGL version string: 3.2.9737 Compatibility Profile Context
    OpenGL shading language version string: 1.50

    fglrxinfo
    display: :0.0 screen: 0
    OpenGL vendor string: ATI Technologies Inc.
    OpenGL renderer string: ATI Radeon HD 5800 Series
    OpenGL version string: 3.2.9737 Compatibility Profile Context

  8. #8
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    607

    Default

    this feels more and more like a monologue

    I "feel" no increased latency during minimizing and maximizing of windows anymore:

    has the backclear patch been incorporated into the official Lucid Lynx X-Server or did the driver get that far superior ?

  9. #9
    Join Date
    Jun 2009
    Posts
    1,020

    Default

    Quote Originally Posted by kernelOfTruth View Post
    this feels more and more like a monologue

    I "feel" no increased latency during minimizing and maximizing of windows anymore:

    has the backclear patch been incorporated into the official Lucid Lynx X-Server or did the driver get that far superior ?
    well they seems to finally got someone to do some basic quality assurance in the driver, i noticed that too and for first time in ages crossfire actually works without make a havoc of straces and black screens in my rig. my summary would

    1. crosffire works +1
    2. better 2d performance +1(finally!!!!)
    3. 3d seems quite fast too +1 (basic 3d at least)
    4. savages2 got a horrible noise in the audio but it renders fine -1
    5. wine screwed as always at least for my games -1
    6. video is super teared as normal -1
    7. flash 10.1 with gpgpu works quite good now +1
    8. dont work with preemptive kernels -1
    9. composite works again lol +1
    10. as always fglrx crash badly when you shutdown your pc -1

    is not anything close to nvidia yet but is nice to finally see some love in the driver you know, and yes im pretty sure the xorg is patched

    btw passing acpi=noirq helps with some issues

  10. #10
    Join Date
    Oct 2007
    Posts
    91

    Default

    According to an article on Phoronix, this issue may be fixed. I'm tempted to give 10.04 + fglrx another try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •