Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: Ubuntu 10.04 Gets A New Catalyst Pre-Release

  1. #11
    Join Date
    Aug 2008
    Posts
    116

    Default

    Quote Originally Posted by d2kx View Post
    8.723.1-100408a-098580C-ATI

    The driver runs fine for me with Ubuntu Lucid :-)

    Except the known issues, like the horrible 2D performance while Direct2D isn't stable yet.
    Direct2D? Either Michael didn't report on a (for MS) groundbreaking move or Direct2D is still a MS-only technology.

  2. #12
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,175

    Default

    Quote Originally Posted by Tares View Post
    Any updates with 3D regression since 10.3 ?
    It seems there are several fixes for 3D/OpenGL included. Try if your problems still exist.

    Quote Originally Posted by JeanPaul145 View Post
    Direct2D? Either Michael didn't report on a (for MS) groundbreaking move or Direct2D is still a MS-only technology.
    Michael *did* report on that. Direct2D is coming soon with the Catalyst driver as the new 2D acceleration architecture.

  3. #13
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,572

    Default

    It's not Direct2D, btw, it's a different API that shares some core acceleration code. Think of it as "AAA" or something like that.

  4. #14
    Join Date
    Aug 2008
    Posts
    116

    Default

    Quote Originally Posted by d2kx View Post
    It seems there are several fixes for 3D/OpenGL included. Try if your problems still exist.



    Michael *did* report on that. Direct2D is coming soon with the Catalyst driver as the new 2D acceleration architecture.
    I went looking for it and indeed found it. My browser even indicates I've seen that particular article. I guess my only remaining questions are: How is that even possible? Won't MS object to that? And *what* exactly will Direct2D4Linux accelerate?

  5. #15
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,572

    Default

    It's not Direct2D, it's a different API that shares some core acceleration code.

  6. #16
    Join Date
    Jun 2009
    Location
    Estonia
    Posts
    151

    Default

    anyone able to play opengl games with this driver?

    for example HoN returns me:

    xpander@xpander-desktop:~$ '/home/xpander/Games/HoN/hon-x86'
    warning: The VAD has been replaced by a hack pending a complete rewrite
    K2 - Fatal Error: ARB_vertex_buffer_object not available.

  7. #17
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    642

    Default

    3D stuff is still segfaulting:

    glxinfo, glxgears, compiz, xscreensaver-gl stuff, etc.

    exception and only working program (probably due to 32bit and bundled own libs) is googleearth what on earth ?

    system: ~amd64, gcc 4.4.3 currently moving from fPIE & fstack-protector-all to vanilla compiler, hopefully that makes a change,
    around 60% is already re-compiled

    card: 5850

    distribution: Gentoo

    for more info: http://forums.gentoo.org/viewtopic-t...ighlight-.html

    many thanks in advance for any comment, fix, help, etc.


    please make 10.4 usable again !

    10.1 was the last usable driver for me - all others: 10.2, 10.3 lead to segfaulting apps

  8. #18
    Join Date
    Aug 2007
    Posts
    6,675

    Default

    You know that you have to use Xserver 1.7 for this prerelease?

  9. #19
    Join Date
    Aug 2008
    Posts
    116

    Default

    Quote Originally Posted by bridgman View Post
    It's not Direct2D, it's a different API that shares some core acceleration code.
    Ah. Thanks for sharing that John.

    As the Dutch saying goes, "Nu komt de aap uit de mouw"!

    So if it's not D2D, what's it going to be called? And my other question remains: what exactly will it accelerate? Will it be a low-level "engine" replacement for the Linux Catalyst EXA code?

  10. #20
    Join Date
    Jan 2009
    Location
    Vienna, Austria; Germany; hello world :)
    Posts
    642

    Default

    Quote Originally Posted by Kano View Post
    You know that you have to use Xserver 1.7 for this prerelease?
    yeah, of course, each time I have to unmask xorg-server 1.7 for this stunt


    with xorg-server 1.6.5 I only get a black screen

    so it should be obvious - there are no error message in Xorg.0.log however

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •