Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: HD 3450 incredibly hot when idle using RadeonHD

  1. #1
    Join Date
    Apr 2010
    Posts
    14

    Default HD 3450 incredibly hot when idle using RadeonHD

    My Mobility Radeon HD 3450 GPU for my laptop idles around 68 C, and at peak reaches nearly 100 C. It used to run at about 55 C idle with fglrx. It does not engage thermal cutout nor switch on the fans unless the AC power is removed (running on battery).

    Does anyone know how I can get it to run cooler, even at the expense of performance?

    I'd really like to use radeonhd over fglrx because:
    - it works with screen capture programs (read: fglrx hits 100% cpu at 2 seconds per frame trying to record the desktop, while radeonhd will easily do 20 fps),
    - it is faster to boot (boot also looks prettier - fglrx switches to 800x600 and then to 1280x800 while radeonhd starts with 1280x800),
    - the virtual terminals work better,
    - I haven't noticed a performance drop except in the occasional game or scene and;
    - the less closed source software that runs on the laptop the better.

    Any help appreciated. I'm running Ubuntu 10.04 Lucid Lynx Beta 2.

    Here's version info from Xorg.log:

    Code:
    (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
    (II) Module radeon: vendor="X.Org Foundation"
    	compiled for 1.7.6, module version = 6.12.192
    	Module class: X.Org Video Driver
    	ABI class: X.Org Video Driver, version 6.0
    I don't see anything in the Xorg log about power saving though. Perhaps it has to be enabled, but I'm not sure, as I can't find anything about that.

    Thanks.

  2. #2
    Join Date
    Jun 2009
    Posts
    2,932

    Default

    For powersaving you will either need the radeon driver with ForceLowPowerMode on (assuming you are running user mode setting), or the latest 2.6.34 kernel running with kernel modesetting (KMS).

    I'm not sure whether KMS works with the RadeonHD driver, it didn't use to. But you need KMS to get the advantage of all new developments, such as OpenGL 2+, powersaving and seamless terminal switching. I think that most people are running the radeon driver now.

    Powersaving is a rather recent development and is still not perfect, but it should cool your card down, and it will get better with time. Until recently, most of the cards were running at full blast all the time with free drivers, which explains the fact that it's hot.

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    My recollection was that the radeonhd driver also had the ForceLowPowerMode option. Are you using that option now ?

  4. #4
    Join Date
    Apr 2010
    Posts
    14

    Default

    I don't know about power saving in the kernel or KMS; is there a way to find out if this is enabled?

    I do have seamless terminal switching; the virtual terminals are the same resolution as my main display and there is no flicker when switching between them.

    What I know is that I am using the default install of RadeonHD which works out of the box for my card on Ubuntu. I inserted the LiveCD and had all desktop effects working immediately. The kernel version is "Linux jupiter 2.6.32-19-generic #28-Ubuntu SMP Thu Apr 1 10:39:41 UTC 2010 x86_64 GNU/Linux" and the Xorg server is 1.7.6.

    How would I enable the ForceLowPowerMode option? Is there a way to toggle it without restarting Xorg, so I can play a game in high power mode, but run the rest of the system in low power mode? That would be great.

    If I need a newer kernel I don't mind compiling one, I've done it before, but if I can do it without compiling one it would of course be easier.

    Thanks.

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    If you're using the out-of-box default for Ubuntu Lucid then you are probably running radeon, not radeonhd. You are also almost definitely running with kernel modesetting enabled. The way to be sure of both is to look at the Xorg log - Administration -> System Log Viewer or something like that. Use pastebin or a similar service to let us see the log of you want help interpreting it.

    If you are running radeon and KMS (which seems very likely) your options are :

    (a) pick up a very recent kernel and try the experimental dynamic power management, or

    (b) boot up with user modesetting rather than kernel modesetting by typing something like radeon.modeset=0 at boot time (or in your boot string to make it permanent) and then adding the ForceLowPowerMode option to your xorg.conf.

    Suggest you start with the second one (user modesetting).

  6. #6
    Join Date
    Apr 2010
    Posts
    14

    Default

    Oh, that might explain why it says "RADEON" in the logs. Is there a significant difference between the two drivers? Is one any better (more compatible, faster performance, etc.) than the other?

    I'll put the "radeon.modeset=0" text in the bootstring. Where should I add ForceLowPowerMode to Xorg? I presume it's an option of some kind, so would "yes" do for the value?

    If I compile a 2.6.34 kernel, will this immediately enable power saving, or does more need to be done?

    Thanks.

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,514

    Default

    AFAIK all the common driver options go in the "Device" section. "Yes" should be fine for the value.

    I believe you need radeon.dynpm=1 to enable dynamic PM with a 2.6.34 kernel but not 100% sure.

  8. #8
    Join Date
    Jun 2009
    Posts
    2,932

    Default

    Is there a significant difference between the two drivers?
    Not really.

    The 3d part is handled by Mesa anyway and recently, the memory, DRI2, powersaving and mode setting are handled by the kernel. The X driver basically only provides the X interface and 2D acceleration. And it is similar in both drivers.

    And yes, powersaving is off by default in .34, you have to enable it AFAIK

  9. #9
    Join Date
    Apr 2010
    Posts
    14

    Default

    I just noticed a real bad bug.

    When the sensors get too hot, they read 0C; but only when plugged into AC. Which means Linux doesn't shut down on overtemperature - unless on battery. Just unplugged to find the GPU at 90C; fan is now frantically running trying to cool it down. For now I'm going to be fixing the card to low power mode to stop this, before I get the time to compile the kernel.

    On kernel.org, I presume "mainline" is fine for me.

    Thanks for everyone's help in solving a nasty bug/issue.

  10. #10
    Join Date
    Apr 2010
    Posts
    14

    Default

    OK, I put the following text into an empty /etc/X11/xorg.conf file (because there wasn't one there beforehand.)

    Code:
    Section "Device"
            Identifier      "ATI-Fix"
            Driver          "radeon"
    	Option		"ForceLowPowerMode" "yes"
    EndSection
    I am not noticing a difference - still 68C - am I missing something?

    Tomorrow, I may temporarily have to switch to fglrx before I go out, because otherwise my laptop will overheat.

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •