Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: So now that ATI 10.04 Driver is out how can i install kernel 2.6.33 properly?

  1. #1
    Join Date
    Feb 2010
    Posts
    36

    Default So now that ATI 10.04 Driver is out how can i install kernel 2.6.33 properly?

    the current fglrx driver is causing errors when i try to install 2.6.33 kernel
    is there a way to fix it or should i install it anyway and fix the problem within the kernel?

    thanks in advance.

  2. #2
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    I use those patches in my script:

    http://aur.archlinux.org/packages/ca...x-2.6.33.patch
    http://aur.archlinux.org/packages/ca...6.34-rc4.patch

    Those seem to work well. You should write what distro you use.

  3. #3
    Join Date
    Feb 2010
    Posts
    36

    Default

    ubuntu 10.04 rc/final i'm not sure because i didn't had much updates in the last few days.

  4. #4
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    ok. run

    http://kanotix.com/files/install-fglrx-debian.sh

    then do to put fglrx on hold - the lucid package has not .33/.34 kernel support:

    Code:
    sudo -i
    echo fglrx hold|dpkg --set-selections
    echo fglrx-amdcccle hold|dpkg --set-selections

  5. #5
    Join Date
    Feb 2010
    Posts
    36

    Default

    But i need the fglrx driver why do i need to put it on hold and does this hold is just for 2.6.33 or also for current kernel?

  6. #6
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    My script installs fglrx in a prepatched variant. Just execute it.

  7. #7
    Join Date
    Feb 2010
    Posts
    36

    Default

    Ok let me get it straight i install 2.6.33 boot into it download
    http://kanotix.com/files/install-fglrx-debian.sh

    and then
    Code:
    sudo -i
    echo fglrx hold|dpkg --set-selections
    echo fglrx-amdcccle hold|dpkg --set-selections
    or first i download this:
    http://aur.archlinux.org/packages/ca...x-2.6.33.patch

    and run it and how excecly do i run it because i tried and did not managed to do that.

  8. #8
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    you dont need that extra patch, its included in my script. you need that only for other distros where my script can not used.

  9. #9
    Join Date
    Feb 2010
    Posts
    36

    Default

    i'm now in 2.6.33 kernel i'm trying to run install-fglrx-debian.sh using sudo sh install-fglrx-debian.sh but i get

    Error: No KANOTIX found. Do not ask for support!
    Error: Can`t be run within X! Use a text console (ALT-CTRL-F1)

    when i press alt-ctrl-f1 nothing happen it does not response and the strange thing is that it also didn't worked in 2.6.32-21 all i got was a black screen.

  10. #10
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    That is the problem when you have got fglrx installed but no kernel module, then you can not switch it. Best remove fglrx first:

    Code:
    sudo -i
    apt-get remove --purge fglrx
    rm -f /etc/X11/xorg.conf*
    reboot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •