Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: HD4850+lucid+fglrx = horrible performance

  1. #11
    Join Date
    Nov 2009
    Posts
    328

    Talking

    jaja vsync issue the 300 number hided that to me!

    now i am getting 17822 frames in 5.0 seconds on lucid vsync off.

    A month ago i forced vsync on to totally avoid video tearing. I didn't remember that.

    Arch no idea what is your problem , but maybe is not fglrx fault at all.

  2. #12
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,418

    Default

    Quote Originally Posted by Arch View Post
    Nope, it's turned off. Turning it on does limit me to the 300 frames per 5 seconds Jimbo experiences. Performance of the apps i mentioned is the same either way though.
    I was actually replying to Jimbo; he had an easier question

    Quote Originally Posted by Arch View Post
    What I don't get is why enabling compiz is actually increasing performance. Is there like a different mode when not using effects that isn't being accelerated (anymore)?
    We saw something similar in the early days of 6xx/7xx acceleration; not sure if the issues are related though. In the 6//7xx case the implementation of overlapping blits (where source and dest areas overlapped) was very slow at first, so scrolling was kinda sluggish. When running with a compositor, however, it seemed that the overlapping blits were used much less -- presumably the app just "panned" the area that was composited or something rather than having to move everything within the buffer.

  3. #13
    Join Date
    Jan 2010
    Posts
    17

    Default

    Quote Originally Posted by Jimbo View Post
    Arch no idea what is your problem , but maybe is not fglrx fault at all.
    I'm under the impression that I had around 40000 frames in 5 seconds with Karmic + fglrx 10.2 (exactly the same hardware, of course). So that drop is quite significant (which is why i called performance abysmal =) )

    But yes, I don't think it's fglrx's fault per se, the differences between 10.2 and 10.4 are probably not that significant. So the problem would have to be with either the xserver or my configuration, right?

    As I said, i also tried the oss-drivers and their performance was solid, about the same as I had on Karmic until i turned off KMS, which basically rendered the system useless. Could this be related, as fglrx (as far as I gathered) disables kms as well? Is there some option that needs to be on when kms is off?

  4. #14
    Join Date
    Nov 2009
    Posts
    328

    Default

    I use different partitions to not mess OSS (xorg edgers) with fglrx. I Usually work with fglrx but from time to time I boot with xorg edgers and try to run some demos, wine... to see the development of ati oss.

    On "fglrx partition" I simply run aptitude install fglrx and aticonfig --initial and all is working fine. I din't touched any KMS configuration!!. When you install fglrx it automatically disables KMS.

    The problem you are suffering sounds to me a miss configuration of some type, or maybe compiz+fglrx issue ?

  5. #15
    Join Date
    Jan 2010
    Posts
    17

    Default

    Quote Originally Posted by Jimbo View Post
    On "fglrx partition" I simply run aptitude install fglrx and aticonfig --initial and all is working fine. I din't touched any KMS configuration!!. When you install fglrx it automatically disables KMS.
    That's exactly how my current system was set up. (I did try several configurations with oss and fglrx yesterday, but always ended up doing a clean reinstall).

  6. #16
    Join Date
    Nov 2009
    Posts
    328

    Default

    I don't use compiz, if you have time, try an installation without compiz, this is the only difference i see between your system and mine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •