Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 8.35.5 driver fails to load on recent Fedora Rawhide (upcoming F7)

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Location
    The Netherlands
    Posts
    31

    Default 8.35.5 driver fails to load on recent Fedora Rawhide (upcoming F7)

    Hi all,

    First post to the forum although I have been reading the articles with keen interest. Now about my problem. I have a laptop with an X1300 and Fedora F7 Test 3 updated to the latest Rawhide. Today I build and installed the 8.35.5 drivers/apps, modified my xorg.conf and started X. No go. Apparently some versioning changed in the xorg server part which fglrx disagrees with causing X not to start. It gives this error:

    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.1.0, module version = 8.35.5
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 1.0
    [atiddxSetup] X version mismatch - detected X.org 1.3.-1.905, required X.org 7.1.0.0
    (II) UnloadModule: "fglrx"
    (II) Unloading /usr/lib/xorg/modules/drivers//fglrx_drv.so
    (EE) Failed to load module "fglrx" (module requirement mismatch, 0)

    Anyone have an idea if there is a fix for this issue?

  2. #2

    Default

    Welcome to the forums.

    I am the Fedora package maintainer for the official fglrx drivers, and unfortunately there is no fix at this time as the issue relies within the closed source portion of the driver. Unfortunately, it doesn't look like it will work either with this month's 8.36 driver release (I tried it and it failed).

  3. #3
    Join Date
    Apr 2007
    Location
    The Netherlands
    Posts
    31

    Default

    Quote Originally Posted by Michael View Post
    Welcome to the forums.

    I am the Fedora package maintainer for the official fglrx drivers, and unfortunately there is no fix at this time as the issue relies within the closed source portion of the driver. Unfortunately, it doesn't look like it will work either with this month's 8.36 driver release (I tried it and it failed).
    Thanks for the info Michael. It's not a big issue since it's Rawhide. But it sure would be nice if this issue were fixed when F7 is released. I look forward to the release of 8.36 and play with it. By the way thanks for making it so easy to build the RPM packages. Much appreciated!

  4. #4
    Join Date
    Apr 2007
    Location
    The Netherlands
    Posts
    31

    Default

    Quote Originally Posted by Michael View Post
    Welcome to the forums.

    I am the Fedora package maintainer for the official fglrx drivers, and unfortunately there is no fix at this time as the issue relies within the closed source portion of the driver. Unfortunately, it doesn't look like it will work either with this month's 8.36 driver release (I tried it and it failed).
    Hi Michael. Can you confirm that it still does not work with the final release of 8.36.5 (if different from what you already tested)? Thanks!

  5. #5

    Default

    I tried like 8.36.3 (internal) and it still didn't work with no luck but will try 8.36.5 shortly.

  6. #6
    Join Date
    Apr 2007
    Location
    The Netherlands
    Posts
    31

    Default

    Quote Originally Posted by Michael View Post
    I tried like 8.36.3 (internal) and it still didn't work with no luck but will try 8.36.5 shortly.
    Don't bother. Just tried it and it fails.

  7. #7
    Join Date
    Mar 2007
    Posts
    36

    Default

    Now this is confirmed in debian sid too. And as soon as the 1.3 xserver-xorg-core drifts into Debian testing, ATI will have achieved the remarkable result of having NO drivers that work in new Linux systems like Debian or Fedora. And for users of newer cards unsupported by xorg ati or radeon drivers, they now have no real driver to run at all. I hope somebody at AMD can figure out just why ATI is doing this and solve the problem, very shortly ATI will become a total pariah in the Linux community, even worse than it currently is.

    I believe that Ubuntu solved this issue by recompiling their xorg parts to show the 7.x numbering.

    This is really impressive, if there was any doubt at all that ATI is completely either unwilling or unable to serve Linux users, it is now completely removed.
    Last edited by gfxdrone; 04-20-2007 at 03:24 PM.

  8. #8
    Join Date
    Apr 2007
    Posts
    17

    Default

    I tried last night to build the RPM packages on an up-to-date version of Rawhide and it failed to build, giving the same error as the 8.35 drivers. Was really hoping I might be surprised...

  9. #9

    Default

    Quote Originally Posted by janl View Post
    I tried last night to build the RPM packages on an up-to-date version of Rawhide and it failed to build, giving the same error as the 8.35 drivers. Was really hoping I might be surprised...
    I am hoping ATI will had server 1.3 support prior to Fedora 7... Otherwise there's going to be lots of hell.

  10. #10

    Default

    The New Driver will not work on Rawhide?

    oh man -.-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •