Results 1 to 4 of 4

Thread: 1:1 pixelmapping through HDMI, GPU scaling wonít stick through reboot

  1. #1
    Join Date
    May 2010
    Posts
    2

    Default 1:1 pixelmapping through HDMI, GPU scaling wonít stick through reboot

    Hello everyone!

    Iíve recently bought a new HTPC setup and ran into some issues with overscan/underscan using the newest 10.4 catalyst for linux. My previous card was from Nvidia so Iím lacking experience with ATI cards.

    Almost every fix Iíve tried so far resulted in overscan or underscan.
    Setting the underscan-slider to 0% gets me close to a perfect picture but thereís still a 1" black bar on the right of the screen a well as a 0.5" black bar on top of the screen.

    After hours of trying Iíve finally found a method that will give me 100% flawless 1:1 pixel mappingÖ but it wonít stick through reboots.

    I have to set the resolution to something below native 1080p (in my case I just used 1024x768), apply the resolution, change the Catalystís scaling options from "Display" to "GPU - Centered timings".
    Once that is done I restore 1920x1080 and voilŠ, zero black bars, zero overscan.

    Unfortunately this does not stick through reboots. Whenever I open the CCC after a reboot, the Scaling options have jumped back to "Display" instead of "GPU - Centered Timings".

    Has anyone found a workaround for this?
    Iím wondering if it would be viable to do all these steps via a shell script on every boot, but I havenít yet figured out how to change the scaling mode through aticonfig instead of CCC (if that is possible at all?)

    Using:
    Fresh Ubuntu 10.04 installation with Catalyst 10.4
    Radeon 5770
    Pioneer Kuro KRP-600a Plasma connected via HDMI

  2. #2
    Join Date
    Nov 2008
    Posts
    783

    Default

    I've removed underscan on my HDMI output by issuing (once, as root):
    Code:
    aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0
    without any fiddling in amdcccle. Maybe that'll help you?

    otherwise see
    Code:
    aticonfig --help
    IIRC there were options to list and set all configuration keys.

  3. #3
    Join Date
    May 2010
    Posts
    2

    Default

    Thanks, Iíve already tried this but it gives me teh same result as setting Overscan to 0% in the CCC. I suspect the CCC slider is directly linked to this command.

    Upon closer inspection I now believe that this is not a overscan/driver related issue but that the exact timings are a bit off when the CCC is set to letting the monitor scale... no idea why, but it would explain why setting scaling to "Centered Timings" corrects the issue temporarily.

    Now I just have to figure out how to adjust HSyncStart/HSyncEnd and VSyncStart/VSyncEnd when using fglrx.
    Normally I would just adjust the ModeLine but fglrx seems to generate these on the flyÖ there has to be some way to override the EDID specs.

  4. #4
    Join Date
    Nov 2008
    Posts
    783

    Default

    there are some more commands behind this link (further down), but since I didn't need them I have no idea what they'll do for you. Seems obvious that the poster of that entry didn't have a clue what he was doing, either.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •