Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: KWin Can Cause A Performance Hit Too

  1. #11
    Join Date
    Oct 2009
    Posts
    111

    Default

    I am not sure but I think that all theses tests are mood.

    When you do compositing the window manager decides what to paint when, so the fps outputed by a game do not have to match the fps the user sees then. [1] indicates something similiar.

    [1] http://www.kdedevelopers.org/node/3365

  2. #12
    Join Date
    May 2010
    Posts
    684

    Default

    Quote Originally Posted by Pfanne View Post
    for me kwin effects are really slow and choppy with fglrx.
    compiz on the other hand runs smooth
    (im using the backclear patch)
    Same here, kwin is also really bad for me with the open source drivers too :/

  3. #13
    Join Date
    Jun 2009
    Posts
    2,927

    Default

    Does the performance hit occur if the desktop effects are disabled too? Or is it linked to the effects?
    It has to do with compositing, not any effects you switch on.

    KWin can easily suspend compositing (there is a shortcut), but like others have said, it should turn off compositing automatically for fullscreen GL apps. I have certainly never edited any rc files to achieve that.

    I seem to remember a GUI option too, but I can't find it now.

  4. #14
    Join Date
    Aug 2008
    Location
    Finland
    Posts
    1,578

    Default

    Quote Originally Posted by mat69 View Post
    I am not sure but I think that all theses tests are mood.

    When you do compositing the window manager decides what to paint when, so the fps outputed by a game do not have to match the fps the user sees then. [1] indicates something similiar.

    [1] http://www.kdedevelopers.org/node/3365
    You probably did notice the guying say a multitude of times that the video he linked was a fake, right?

  5. #15
    Join Date
    Oct 2009
    Posts
    111

    Default

    Quote Originally Posted by nanonyme View Post
    You probably did notice the guying say a multitude of times that the video he linked was a fake, right?
    You probably did notice the updates right?

    [...] most people probably don't have the knowledge to know that, since compositing is an additional pass, it cannot make things faster in general.

    That conflicts with some of the benchmarks Michael did.

  6. #16
    Join Date
    Jun 2006
    Posts
    351

    Default

    Is Ubuntu really messing up anything it touches ?

    Debian Sid / KDE 4.4.3 / 64bit
    Binary: Linux 64bit GCC 4.3.2 Release Mar 21 2010
    Operating system: Linux 2.6.34-0.slh.4-sidux-amd64 x86_64
    CPU model: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
    CPU flags: 3000MHz MMX+ 3DNow!+ SSE SSE2 SSE3 HTT
    GPU model: GeForce GTS 250 PCI Express 256.25 1024Mb ( it's the same for 196.36.15 or 196.36.24 BTW)

    Render: opengl
    Mode: 1680x1050 4xAA fullscreen
    Shaders: high
    Textures: high
    Filter: trilinear
    Anisotropy: 16x
    Occlusion: enabled
    Refraction: enabled
    Volumetric: enabled
    Replication: disabled
    Tessellation: disabled

    KWin/OpenGL: 590 / 12.5 / 23.4 / 47.5
    KWin/XRENDER: 598 / 12.8 / 23.7 / 47.5
    KWin/NoComp: 599 / 12.8 / 23.8 / 47.7

    NoComp/XRENDER/OpenGL: 100% / 99.8331% / 98.4975%

    Does 1.5% really matter?

    ( BTW Unigine Heaven 2.1 is out with Stereo 3D: http://unigine.com/products/heaven/ and i'll retest as fast as i can )

  7. #17
    Join Date
    Aug 2009
    Posts
    2,264

    Default

    Thanks for running these tests, Michael. I really wanted to know that

  8. #18
    Join Date
    May 2009
    Posts
    43

    Default

    Quote Originally Posted by kbios View Post
    As I posted under the compiz thread, unredirect of fullscreen windows has to be manually enabled in ~/.kde/share/config/kwinrc in kde4. For me (nvidia proprietary driver) it solves choppiness issues when running Unigine.
    May I ask you what's your distro?
    Here kwin suspends compositing just fine without tinkering with config files (Fedora12).
    Maybe that's another Ubuntu thing?

    Just done quick test with Glaxium on i915 no difference between composite and no-composite ~38 fps

  9. #19
    Join Date
    Jun 2006
    Posts
    351

    Default

    Unigine Heaven 2.1

    Binary: Linux 64bit GCC 4.3.2 Release May 20 2010
    Operating system: Linux 2.6.34-0.slh.4-sidux-amd64 x86_64
    CPU model: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
    CPU flags: 3000MHz MMX+ 3DNow!+ SSE SSE2 SSE3 HTT
    GPU model: GeForce GTS 250 PCI Express 256.25 1024Mb

    Render: opengl
    Mode: 1680x1050 4xAA fullscreen
    Shaders: high
    Textures: high
    Filter: trilinear
    Anisotropy: 16x
    Occlusion: enabled
    Refraction: enabled
    Volumetric: enabled
    Replication: disabled
    Tessellation: disabled

    KWin/OpenGL: 613 / 12.8 / 24.3 / 49.9
    KWin/NoComp: 614 / 12.8 / 24.4 / 50.0


    So yeah looks like Ubuntu does make Linux look bad

  10. #20
    Join Date
    Feb 2008
    Location
    Santiago, Chile
    Posts
    240

    Default

    You can check if KWin is compositing with a simple test. Install BeClock, http://kde-apps.org/content/show.php...content=117542 . After that, enable it (get a clock) run your demos.

    If you get a clock running Unigine, KWin is compositing. Almost all the time it does unredirect windows, but sometimes it fails.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •