Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Open ATI R600/700 Driver Gains Tiling Support

  1. #11
    Join Date
    Jul 2009
    Posts
    87

    Default

    No, it's not a LCD if that's what you had in mind. Hooked up is an old IBM P260, running at 85Hz in all resolutions I use.

    So VSync isn't the issue here, I think it's really some game engine setting - gonna have a look at the INIs later.

  2. #12
    Join Date
    Nov 2009
    Posts
    15

    Default

    Just tested color-tiling with SuperTux2 on 1280x800. I observed no regressions and performance is boosted, albeit not as much as previously reported. Depending on the scene, I get an increase from 32 to 40 or from 32 to 60 fps.

    It was really fun to see how color tiling behaves when you forget to patch mesa.

  3. #13
    Join Date
    May 2009
    Location
    Richland, WA
    Posts
    134

    Default

    The initial patch said it was KMS only, When is UMS going to be supported?

  4. #14
    Join Date
    Jul 2009
    Posts
    87

    Default

    Isn't radeon moving in the same direction as intel? KMS-only?

    I consider UMS deprecated and I strongly suggest to use KMS, which works fairly well - even when using stable (vs. experimental) kernels.

  5. #15
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Quote Originally Posted by Obscene_CNN View Post
    The initial patch said it was KMS only, When is UMS going to be supported?
    There are no plans to support it with UMS.

  6. #16

    Default

    Any performance boosts for the R500 cards? My ATI Radeon X1950 has been horridly slow ever since Catalyst dropped suppport for my card.

  7. #17
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,458

    Default

    aliendude, are you running with the classic Mesa HW drivers or the new Gallium3D-based ("300g") stack ? The classic HW drivers are still the default but 300g is getting close enough to becoming the default that it's probably worth giving it a try.

  8. #18
    Join Date
    May 2009
    Location
    Richland, WA
    Posts
    134

    Default

    Quote Originally Posted by LiquidAcid View Post
    I consider UMS deprecated and I strongly suggest to use KMS, which works fairly well - even when using stable (vs. experimental) kernels.
    Well KMS still causes my screen to go black when I boot as soon as the radeon module loads. After I login and start x blind it comes up but my screen on my laptop flickers for about 5 minutes before it solidifies. Every benchmark I run with KMS shows a performance hit.

    I don't think I'm going to switch to KMS anytime soon.

  9. #19
    Join Date
    Dec 2007
    Posts
    2,371

    Default

    Quote Originally Posted by Obscene_CNN View Post
    Well KMS still causes my screen to go black when I boot as soon as the radeon module loads.
    You need to have fbcon loaded or built into your kernel in order to get a console on the fbdev interface provided by the drm.

  10. #20
    Join Date
    Nov 2009
    Posts
    45

    Default

    Are these patches (tiling) in any of the git branches? I don't see them in drm-next or drm-radeon-testing

    I'd like to test these along with the voltage setting patches, but I don't want to mess around with applying these patches manually I'm too lazy to modify my shiny PKGBUILD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •