Results 1 to 6 of 6

Thread: Acer Revoboot (splashtop and grub question)

  1. #1
    Join Date
    Apr 2010

    Default Acer Revoboot (splashtop and grub question)


    I have recently purchased a acer revo r3600.

    It comes with a initial partition layout of:

    sda1 hd0,0 Primary 1: 2GB Active blank
    sda2 hd0,1 Primary 2: 2GB Linux partition, Squashfs.
    sda3 hd0,2: Primary 3 4GB Splashtop - Hidden FAT32

    I have done lots of partition experimentation and from what I've seen the 2gb linux partition is not need to run the splashtop. However its removal does cause the boot os button / Revobuild button to be greyed out.

    I can also move the splashtop primary partition to be a logical drive in an an extended partition and it still works perfectly.

    Having read some of the bugs on this forum I am happy to say it supports the 1680 by 1050 off the bat and I can add .sqx files that work without having to apply any hacks to checking system.

    The question:

    I use grub4dos in my MBR and boot many different OSs on this device. I would like to be able to include splashdot in my grub menu as the bios loader forces a 10 second timeout which I don't know how to change as yet and its too long.

    I assume this is possible if you are using grub in the usb stick to start things off rather than the bios on the system. I've looked into that but is slightly above my head at the moment.

    Could you advise me what I would need to include in the menu would be very helpful or tell me what I want to archieve is not possible so I can stop trying for the time being ^_^.

    I tried something along the line of
    rootnoverify (hd0,5)

    to no avail.

    Ooo in case hd0,5 confuses better mention I've repartitioned the disk alot current table below

    MBR: Grub4dos
    sda1 hd0,0 Primary 1: 30GB Windows 7 Ultimate 32 bit
    sda2 hd0,1 Primary 2: 2GB Linux partition, Squashfs part of revoboot.
    sda3 hd0,2 Primary 3: 30GB Windows XPl
    sda4 hd0,3 Extended:
    sda5 hd0,4 Logical 1: 2GB Grub4dos menu, GDLR, grub installer, various isos for booting e.g. acronis disk director, gpart
    sda6 hd0,5 Logical 2: 4GB Splashtop - Hidden FAT32 (moved from sda3)
    sda7 hd0,6 Logical 3: 2GB Linux Swap 1 for XBMCbuntu
    sda8 hd0,7 Logical 4: 2GB Linux Swap 2 for Full Ubuntu (Two swaps for various reasons)
    sda9 hd0,8 Logical 5: 5GB XBMCubuntu (Cut down version of linux running XBMC)
    sda10 hd0,9 Logical 6: 15GB Ubuntu Linux
    sda11 hd0,10 Logical 7: 10GB Reserved for some quick booting linux with a browser to try later.
    sda12 hd0,11 Logical 8: X GB Remaining space for storage,

    Thank you in advance for any advice.


  2. #2
    Join Date
    Apr 2010


    When i say
    "I would like to be able to include splashdot in my grub menu"
    typo i mean
    "I would like to be able to include splashtop in my grub menu"

    Still catchy name. An a news app to display slashdot on the splashtop os comes to mind.

  3. #3
    Join Date
    Aug 2007


    You need a ce_bz to boot. That was in older expressgate versions. its basically cefull + a linux like header.

  4. #4
    Join Date
    Apr 2010


    I assume best place to obtain it is from asus website in one of their express gate zips.

    You say older version

    looking here

    which would you recommend being so many at 50meg a piece

  5. #5
    Join Date
    Apr 2010


    Hmm well my build has a CEFULL.

    So is it possible to make find the header. I guess from what I read the CE_BZ is a 1536 byte header then the contents of CEFULL.

  6. #6
    Join Date
    Apr 2010


    asus's CE_BZ did not work which is not unexpected.

    I tried removing the header from the v1231 ce_bz and joined it with my cefull in the hope to make a working ce_bz for my install.

    That managed to load the ce_loader that I usually see on the system startup but it only displayed half of the screen as was not inactable.

    My cefull is alot bigger however.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts