Results 1 to 5 of 5

Thread: Vga switcheroo got borked lately (regression)

  1. #1
    Join Date
    Nov 2009
    Posts
    45

    Default Vga switcheroo got borked lately (regression)

    Hi,

    I've got a Lenovo U330 with Intel 4500MHD and Radeon 3450. I've been using kernels from the drm-radeon-testing branch for the extra radeon goodness of them. I used vga switcheroo to alter between the energy efficient Intel and HDMI-enabled Ati cards. It worked ok until kernel from 20100521.

    My previous kernel was from 20100511. When I switch to the Intel card (I must do DDIS, to turn on the radeon card and later DINT to turn the Intel card on) I get a 100% CPu usage from kslowd000. If I try to switch cards once more I get a kernel freeze.

    I reported it to the kernel bug tracker:
    https://bugzilla.kernel.org/show_bug.cgi?id=16086

    Has anyone had any problems with vga switcheroo? I ask because not one of my vga switcheroo bugs got any attention
    https://bugzilla.kernel.org/buglist....rch=switcheroo

    It's unfortunate that the vga_switcheroo had been introduced and largely forgotten It worked really nicely when Airlied introduced it. It seems that noone cares about it anymore

  2. #2
    Join Date
    May 2010
    Posts
    135

    Default

    I never got it to work. Would be nice. First order of business for me is getting suspend to RAM working on my T500.

  3. #3
    Join Date
    Nov 2009
    Posts
    45

    Default

    It actually was pretty easy to get working:

    1. Get kernel 2.6.34
    2. Compile it with CONFIG_VGA_SWITCHEROO=y
    3. Load both i915 and radeon drivers
    4. You should get /sys/kernel/debug/vgaswitcheroo/switch which shows the state of each card, which one is used and which one is powered on.
    5. Delete your xorg.conf, you don't need it anymore
    6. Use echo to set values of: OFF (turn off unused), DDIS (delated switch to discrete card), DINT (delayed switch to integrated card) to switch between cards.
    7. Kill your xorg session to switch between cards.

    It worked well for me, but it doesn't work after 20100511.

  4. #4
    Join Date
    Nov 2009
    Posts
    45

    Default

    Woot It seems that the problems in switcheroo were fixed lately.

    http://git.kernel.org/?p=linux/kerne...54d56972acf58c
    http://git.kernel.org/?p=linux/kerne...d77787035e02eb

    Switching works once again Many many thanks David

    I still get some glitches, though:
    1. When I suspend using radeon, the internal LVDS screen comes back attached to the intel graphics card and is unusable. The HDMI connection (radeon only) works though. Suspending works great under intel card.
    https://bugzilla.kernel.org/show_bug.cgi?id=15850
    2. A minor problem: I can't turn xorg when using intel after doing "OFF" to turn off the radeon card. I need to do "DDIS" followed "DINT" to turn on the radeon card.
    https://bugzilla.kernel.org/show_bug.cgi?id=15851

  5. #5

    Default

    Quote Originally Posted by Neuro View Post
    It actually was pretty easy to get working:

    1. Get kernel 2.6.34
    2. Compile it with CONFIG_VGA_SWITCHEROO=y
    3. Load both i915 and radeon drivers
    4. You should get /sys/kernel/debug/vgaswitcheroo/switch which shows the state of each card, which one is used and which one is powered on.
    5. Delete your xorg.conf, you don't need it anymore
    6. Use echo to set values of: OFF (turn off unused), DDIS (delated switch to discrete card), DINT (delayed switch to integrated card) to switch between cards.
    7. Kill your xorg session to switch between cards.

    It worked well for me, but it doesn't work after 20100511.
    Will it work if i use the kernel 2.6.35rc from ubuntu kernel-ppa ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •