Page 27 of 29 FirstFirst ... 172526272829 LastLast
Results 261 to 270 of 285

Thread: Drivers for linux are rubbish

  1. #261
    Join Date
    Jun 2009
    Posts
    2,933

    Default

    s/older drivers/older chipsets/g

  2. #262
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,544

    Default

    Quote Originally Posted by pingufunkybeat View Post
    That makes sense.

    I didn't know that the support for older drivers was also dropped. Still, they can be installed on a recent Windows machine, because things don't change as often in Windows-land.
    Yeah, we usually drop support on all OSes at the same time. As you pointed out, however, the impact is felt much more quickly on Linux/X/DRI than on OSes where the ability to use older drivers is a requirement for most new OS generations.

  3. #263
    Join Date
    Nov 2008
    Location
    Germany
    Posts
    5,411

    Default

    Quote Originally Posted by cutterjohn View Post
    Hell! I don't know how much they pay bridgman but how he can sit around and spout crap like workstation blah blah is great, I don't know since there isn't a while helluvalot of difference between consumer 3D and workstation!

    AMD just need to get their shit in order.
    amd do have a new fokus for the FGLRX ---> Desktop (Future not past)

    but yes you talk about old -times

  4. #264
    Join Date
    Jun 2010
    Posts
    16

    Default

    HI
    I would really like if anyone can tell me what to install to make my hd 4870 actually work properly with compiz on lucid 64 bit. It's really stressful reading and searching and finding no proper solution on something that seems so basic
    The drivers i installed the recommended ubuntu one that pops up failed. THe proprietary ATI 10.5 drivers failed, at least with the method THEY outtlined to install it
    What should i do. It is totally ruining my ubuntu experience

  5. #265
    Join Date
    May 2007
    Posts
    352

    Default

    Well, first, compiz should have worked with the open source drivers that Lucid shipped with and enables by default for all Radeons.

    Second, it should also work with the proprietary driver that Ubuntu then recommended. But since all you say is that it "failed" no one here is going to be able to help you out. How about some details? How did it fail? Did X fail to start, or did the drivers fail to install? What error did you get? If the drivers from the driver manager didn't install properly, what does your /var/log/jockey.log file say?

    Adam

  6. #266
    Join Date
    Jun 2010
    Posts
    16

    Default

    ok
    'stock' ubuntu, I don't remember trying running compiz extra effects, but what i do know is that the splash screen was 1920x1200 (a good sign). However as it got into ubuntu i was prompted to install drivers, iirc its the fglrx proprietary drivers. I think at that point when installed i got catalyst control centre but i'm unsure. WIll double check later.

    When that is installed however, rebooted, splash screen becomes low res, i will say around 640x480, and pixelated. When i enable extra effects maximising is especially slow, tearing when moving around windows.

    OK, i assume it's driver problem, so i disabled them. Naturally i cannot load extra effects afterward. I then installed the x86_64 bit 10.5 driver from ATI site (with the .run extension). I did sudo sh (Driver name) and i got a graphic install (those were their instructions), i did the express install. That resulted in basically no change afaik. In fact i remember having 2 pairs of catalyst control centres in my system administration list.

    No biggie, I uninstalled ubuntu, this time i ignore the prompt and went straight into installing the ATI proprietary drivers. Still get slow maximising, stlll get tearing. So that's what i mean by failing , the drivers failed. They got installed but I did not get the performance i expected.

  7. #267
    Join Date
    May 2007
    Posts
    352

    Default

    Sorry, but "fail" implies a complete lack of functioning. The tearing and slow maximizing are known issues with fglrx. These things should work with the open source drivers, and while I have no personal experience with the HD4870 it is my understanding that it is supported by the open source drivers. Without the proprietary driver installed, what's the output of 'glxinfo | grep -i render'?

    Adam

  8. #268
    Join Date
    Jun 2009
    Posts
    2,933

    Default

    Quote Originally Posted by hotnikkelz View Post
    'stock' ubuntu, I don't remember trying running compiz extra effects
    They should have worked out of the box, without installing anything.

    FGLRX (proprietary catalyst driver) is known for sub-optimal 2d performance, including slow resizing.

    You will need FGLRX for really heavy 3d work or if you want to run WINE or OpenCL applications. For most other things, including everyday desktop usage and native games, the open source driver is preferable, IMHO.

  9. #269
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,544

    Default

    OK, let's see...

    First, you have more or less the same thread repeated all over the forum, and each one only has a portion of the information needed to help. Can you add a post to each of those other threads and redirect them here ?

    The delays maximizing under Compiz are a consequence of a decision a year or so ago to remove a long-standing X server patch (the "fedora no backfill" patch) which had been added a few years ago to get good performance with XAA acceleration. The patch was removed in 2009 distro releases since it caused problems with a new driver from another HW vendor. It's not a driver failure, just that the X server in Lucid ships without the patch that was needed to get good performance with Compiz and XAA acceleration.

    We proposed a new patch, called "backclear", which replaces the no-backfill patch, eliminates the delays, and works OK with the other vendor's new driver as well. If you want to keep running the proprietary driver without the maximizing delays you can obtain a pre-patched X server... I don't remember the link for the repo you add but it's been posted a few times here.

    Alternatively, during Lucid installation you can decline the installation of proprietary driver and run with the out-of-box open source drivers. They won't have the same 3D performance and features (slower, and GL 2.0 support vs GL 4.0) but will work quite well for everyday use.

  10. #270
    Join Date
    Jun 2010
    Posts
    16

    Default

    Thanks adamk, pingufunkybeat, brigman for the help so far. I'm going to only post in this thread now. I don't know how to redirect, sorry.

    adamk:
    I wasn't being technical when i said 'fail', forgive me (was using gaming terms). I thought i understood what was going on, but your post confused me a bit. What are these open drivers you speak ok? I was under the impression that fglrx was half open/half proprietary? and of course ATI linux 10.5 was fully proprietary. That's the only drivers i know of and tried. What drivers do stock ubuntu come with that enables my card to work well with compiz straight out of the box. Shouldn't installing a recent ATI driver give me even better performance? I have a feeling i will need ATI over stock ubuntu when it's time to game.

    pingu:
    I want to eventually use WINE among other things as i intend to use Ubuntu as my main OS. But i cannot continue if these issues remain unresolved, i have to be sure, everything will work well as it is. Hence i MUCH preferred to use ATI's drivers over the FGLRX cuz i expected better performance, also I assumed i will need that when it's time for gaming. Still don't know what are the open drivers hahaha forgive my newbiness.

    bridgman:
    Again thanks for explaining the issue. Again it irks me they ship Lucid without the patch WHen u say proposed 'backclear' you mean it's still in developement, and by other vendor you mean those on the fglrx side or the open source side right? Seems like fglrx is definitely the way i don't want to go. YES! i want to use ATI's proprietary driver that i downloaded. SO all i need to do is find the pre-patched X server, and I'll be good to go judging by what u said. I will do as you recommend and irnogre ubntu's driver prompt and work with the stock until i find the x server pre patch. Will post my results when i'm able

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •