Results 1 to 5 of 5

Thread: X.Org Server 1.8 Being Pulled Into Ubuntu 10.10 Soon

  1. #1
    Join Date
    Jan 2007
    Posts
    14,361

    Default X.Org Server 1.8 Being Pulled Into Ubuntu 10.10 Soon

    Phoronix: X.Org Server 1.8 Being Pulled Into Ubuntu 10.10 Soon

    While many new packages have been pulled into the "Maverick Meerkat" repository for Ubuntu 10.10, one area that hasn't yet received many changes compared to the Ubuntu 10.04 LTS packages has been the X.Org graphics stack. However, that soon will change with X.Org Server 1.8 being pulled into the Maverick repository in the very near future...

    http://www.phoronix.com/vr.php?view=ODMyMw

  2. #2
    Join Date
    Jul 2009
    Posts
    90

    Default

    The proprietary NVIDIA driver is also compatible with X.Org Server 1.8, but to no surprise, the ATI Catalyst Linux driver from AMD is not yet compatible. This means that those tracking Ubuntu 10.10 "Maverick Meerkat" right now will be forced to use the open-source ATI graphics stack as the fglrx/Catalyst driver will not work. At some point before October, however, AMD should introduce the needed support and we just need to hope they'll be quick with their adjoining X.Org Server 1.9 support that is entering Maverick later in the cycle.
    Well the AMD driver works quite well if you run a patched 1.8 server that reports itself as 1.7

    It looks like AMD just has to add the version string for the xserver in the driver.

  3. #3
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    Well did not test xserver 1.8 yet, but i thought ati did not check the version string anymore. This was definitely not the error with 1.7 - unresolved symbols have been there. Can you show me the error with your 1.8 without version fake? I removed version checks within the fglrx binary driver for xserver 1.4, but i guess U will get a prerelease driver for xserver 1.8.

  4. #4
    Join Date
    Jul 2009
    Posts
    90

    Default

    Code:
    [   152.504] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [   152.504] (II) Module glx: vendor="FireGL - ATI Technologies Inc."
    [   152.504] 	compiled for 7.5.0, module version = 1.0.0
    [   152.504] (II) Loading extension GLX
    [   152.504] (II) LoadModule: "fglrx"
    [   152.504] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
    [   152.511] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    [   152.511] 	compiled for 1.7.1, module version = 8.73.3
    [   152.511] 	Module class: X.Org Video Driver
    [   152.511] [atiddxSetup] X version mismatch - detected X.org 7.1.1.0, required X.org 7.5.1.0
    [   152.511] (II) UnloadModule: "fglrx"
    [   152.511] (II) Unloading /usr/lib/xorg/modules/drivers/fglrx_drv.so
    [   152.511] (EE) Failed to load module "fglrx" (module requirement mismatch, 0)
    [   152.511] (EE) No drivers available.
    [   152.511]
    [atiddxSetup] X version mismatch

  5. #5

    Default

    Whats with all this AMD bashing? If I were AMD I think I would give up supporting Linux because of a new Xorg, kernel, libs release every two weeks which breaks again everything.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •