Quote Originally Posted by Hans View Post
I had the same issue. You have to purge uninstall the old fglrx driver.
Then you have to completely remove /etc/ati and /usr/lib/fglrx

Now reinstall fglrx 10.6 and run sudo aticonfig --initial --force and all is good.
Holy heck, you're right! That did it. Thank you greatly!
aticonfig --initial --force did the trick. But how was I supposed to know that. This was never required before.

Now the question remains: Why on earth does this still not happen automatically? I still don't trust ATI to make a proper deb package, so... Kano?