Results 1 to 10 of 10

Thread: Linux and game performance

Hybrid View

  1. #1
    Join Date
    May 2009
    Location
    Warren, Ohio, USA
    Posts
    14

    Default Linux and game performance

    For a year or more, I've noticed problems with running Enemy Territory: Quake Wars in Linux.

    One problem, is micro-stutter, and another problem is mouse lag (especially when zoomed w/ sniper rifle)

    My memory may not be correct, but I don't recall having these problems several kernels ago... Like around the time Quake Wars came out.

    I've searched quite a bit online, tried several workarounds, like disabling compositing, using OSS or ALSA, different recent kernels, and different nvidia driver versions, to no avail.

    Even setting the details to low and disabling anti-aliasing does not seem to make a difference.

    Upgrading my CPU from an AMD dual core 5000+ (which IIRC, used to work fine, many kernels ago) to a quad core Phenom II X4 945 seems to have made no difference.

    Out of curiosity, I tried installing the game in Vista, and it seems to exhibit none of these problems... Runs perfectly fine.

    One of the posts in my internet searches stated that using the BFS scheduler fixed the problem... I've not tried it myself.

    So is there something screwy going on with Linux CPU scheduler/xinput that degrades game performance?

    Just something I'm curious about. Wondering if others are having similar experiences.

    -Andy

  2. #2
    Join Date
    May 2009
    Location
    Warren, Ohio, USA
    Posts
    14

    Default

    This should probably be moved to the gaming forum, sorry.

    -Andy

  3. #3
    Join Date
    Nov 2008
    Location
    UK
    Posts
    59

    Default

    Not noticed any problems myself, that's was on a amd 3800xp and a 7800 gtx.

    On a amd 1095 BE and a 5870 and still fine.

    Is it on a certain map?


    Pete

  4. #4
    Join Date
    May 2009
    Location
    Warren, Ohio, USA
    Posts
    14

    Default

    Sorry, I guess I could have given more info.

    It's actually the demo.

    My system runs Kubuntu 10.10 64-bit, though I've tried earlier versions and even a 32-bit install. Same issue.

    Tried Ubuntu's kernel, compiling my own kernel, optimizing it for K8, and 1000hz, and preempt, etc. etc.

    Think I even tried an RT kernel.

    I do seem to recall hearing somewhere that it could be a problem specific to the demo... If you end up with some time and bandwidth to kill, I'd be curious if the demo might act up for you where the full game does not?

    System is:

    AMD Phenom II X4 945 @ 3Ghz
    GeForce 8800GTS 640MB (think it is an MSI)
    Thermaltake 480W power supply
    GA-M57SLI motherboard (nForce 570 based)
    4GB DDR-800 Corsair RAM
    Seagate 500GB SATA hard drive
    Sound Blaster Audigy

    I'm not sure if this is related or not, but I also seem to get micro-stutter when playing Vice City in WINE.

    I realize one shouldn't expect perfect performance from WINE, but on this system I would expect it to be better than it is, particularly for an older game.

    WINE seems broken in 10.10 for me, so I'll have to wait to see if that is still an issue.

    -Andy

  5. #5
    Join Date
    May 2009
    Location
    Warren, Ohio, USA
    Posts
    14

    Default

    On another note, I've been using nVidia since the GeForce DDR, recommending it since the TNT2, but I'm seriously considering getting my first ATI card, a 5870.

    Has comparable performance to the high-end fermis and is about $100 cheaper. How do you like it?

  6. #6
    Join Date
    Jun 2009
    Location
    Estonia
    Posts
    141

    Default

    i miself used geforce 8800GTS pretty long time and at the beginning of this year i switched to ATI (hd 5770), so far so good, native games run defenetly better than with my old card, but some wine games have more ati related issues (alltho its slowly getting better on that area).

    basicaly im happy with ATI and dont have any bad words about their driver..except their late xserver support.

  7. #7
    Join Date
    Jun 2006
    Posts
    3,046

    Default

    Quote Originally Posted by personman View Post
    So is there something screwy going on with Linux CPU scheduler/xinput that degrades game performance?
    It's entirely possible.

    Just something I'm curious about. Wondering if others are having similar experiences.

    -Andy
    Not having experienced it with my main machine, my HTPC, or my laptop- but then, I have a bit more aggressive hardware.

    I guess I could check and see if there's something noxious going on- I know for a fact that behaviors in the scheduler can make or break you. fglrx had a performance hit for the longest time because of a mis-match with the scheduler and it's handling of things. Stall the pipeline at the wrong time and you can lose half or more of your performance- or worse, go to slideshow framerates. I've seen it happen with X1950's back when those were the big thing.

  8. #8
    Join Date
    Jul 2010
    Location
    United States
    Posts
    5

    Default

    i do not take credit for this script, the credit for this script goes to "cogadh" at the ubuntu forums
    here's how the script works it launches a seperate x server to gain some performance boost, all you have to do is open the terminal, make sure your logged in as root
    and type this

    #!/bin/sh
    #uncomment if launching from console session
    #sudo /etc/init.d/gdm stop
    #KDE use this instead
    #sudo /etc/init.d/kdm stop

    # Launches a new X session on display 3. If you don't have an Nvidia card
    # take out the "& nvidia-settings --load-config-only" part
    X :3 -ac & nvidia-settings --load-config-only

    # Goto game dir (modify as needed)
    cd "~/.wine/drive_c/Program Files/Game/Directory/"

    # Forces the system to have a break for 2 seconds, X doesn't launch instantly
    sleep 2

    # Launches game (modify as needed)
    DISPLAY=:3 WINEDEBUG=-all wine "C:/Program Files/Game/Directory/game.exe"

  9. #9
    Join Date
    Jul 2010
    Location
    United States
    Posts
    5

    Default

    i do not take credit for this script, the credit for this script goes to "cogadh" at the ubuntu forums
    here's how the script works it launches a seperate x server to gain some performance boost, all you have to do is open the terminal, make sure your logged in as root
    and type this . Real time chicago Real Estate listings!

    #!/bin/sh
    #uncomment if launching from console session
    #sudo /etc/init.d/gdm stop
    #KDE use this instead
    #sudo /etc/init.d/kdm stop

    # Launches a new X session on display 3. If you don't have an Nvidia card
    # take out the "& nvidia-settings --load-config-only" part
    X :3 -ac & nvidia-settings --load-config-only

    # Goto game dir (modify as needed)
    cd "~/.wine/drive_c/Program Files/Game/Directory/"

    # Forces the system to have a break for 2 seconds, X doesn't launch instantly
    sleep 2

    # Launches game (modify as needed)
    DISPLAY=:3 WINEDEBUG=-all wine "C:/Program Files/Game/Directory/game.exe"

  10. #10
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    I might use

    metacity --replace &

    or disable compiz/kde 4 effects in the menu by default as i don't need em at all, but using a new xserver is certainly also possible. You should not shutdown your dm as you can easyly switch using ctrl+alt+fX. If you want to start your game via cli (no need for root!), just run

    startx $(which xterm) -- :1

    be sure you config it to use full screen res.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •