For a year or more, I've noticed problems with running Enemy Territory: Quake Wars in Linux.

One problem, is micro-stutter, and another problem is mouse lag (especially when zoomed w/ sniper rifle)

My memory may not be correct, but I don't recall having these problems several kernels ago... Like around the time Quake Wars came out.

I've searched quite a bit online, tried several workarounds, like disabling compositing, using OSS or ALSA, different recent kernels, and different nvidia driver versions, to no avail.

Even setting the details to low and disabling anti-aliasing does not seem to make a difference.

Upgrading my CPU from an AMD dual core 5000+ (which IIRC, used to work fine, many kernels ago) to a quad core Phenom II X4 945 seems to have made no difference.

Out of curiosity, I tried installing the game in Vista, and it seems to exhibit none of these problems... Runs perfectly fine.

One of the posts in my internet searches stated that using the BFS scheduler fixed the problem... I've not tried it myself.

So is there something screwy going on with Linux CPU scheduler/xinput that degrades game performance?

Just something I'm curious about. Wondering if others are having similar experiences.

-Andy