Page 3 of 11 FirstFirst 12345 ... LastLast
Results 21 to 30 of 108

Thread: 890GX/HD4290 dual display question

  1. #21
    Join Date
    Aug 2007
    Posts
    6,674

    Default

    Most likely you would need an active dp -> dvi adapter or a monitor with dp connector. That would be the most easy way to try.

  2. #22
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    You only need an active DP->DVI adapter for dual link DVI monitors. As I mentioned earlier, you may need this patch:
    http://git.kernel.org/?p=linux/kerne...3096dc21cf8df8
    to get that port working properly. Can you pastebin your dmesg?

  3. #23
    Join Date
    Aug 2007
    Posts
    6,674

    Default

    But why doesnt he get a POST screen then?

  4. #24
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    In most cases he should, but it depends on the oem/bios. Also, if you have a secondary card in the pcie x16 slot, it will disable the DP port since they share lanes. There really should be a bios option to enable/disable the DP port.

  5. #25
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    You might try adjusting the "GFX Dual Slot Configuration" or the "Internal Graphics Mode" options in the bios.

  6. #26
    Join Date
    Oct 2009
    Posts
    2,145

    Default

    The monitor is a single link. In fact, my DVI wires themselves are only single link (missing the 6 pins in the middle) and work when plugged into the DVI port, so definitely shouldn't be needing any active adapter.

    I've tried now with next-20100716, which includes that patch. No difference. The dmesg for next is here: http://pastebin.com/HjxcNJgG

    I have no cards at all in any of the slots, and there's nothing in the bios to enable the DP. I have looked at those "dual slot" and "internal graphics mode" options, the "internal graphics" option is enable/disable and whether or not to use sideport memory. I don't think that sideport should make any difference to it, but I guess I might as well try just to make sure.

    BTW: sorry it took me a while to get back to this, car window spontaneously self destructed yesterday, had to replace it.

  7. #27
    Join Date
    Dec 2007
    Posts
    2,404

    Default

    Try changing those bios options. The dual slot one may be important as some of the pcie pins are shared for use by the pciephy used by the DP port. The dmesg looks ok. Can you post your xorg log?

  8. #28
    Join Date
    Aug 2007
    Posts
    6,674

    Default

    @droidhacker

    It seems you use a Gigabyte board, press CTRL+F1 to show all options.

  9. #29
    Join Date
    Oct 2009
    Posts
    2,145

    Default

    I'm just about to go through all the bios options again in every possible combination. I've also readied the W7 to test -- if it also fails there, then at least I can conclude that it is either a bios configuration, bios bug, or defective board.

    Here's the xorg log: http://pastebin.com/zvW9RUq9
    Nothing remarkable. It detects the DP as disconnected.

  10. #30
    Join Date
    Oct 2009
    Posts
    2,145

    Default

    Quote Originally Posted by Kano View Post
    @droidhacker

    It seems you use a Gigabyte board, press CTRL+F1 to show all options.
    Its an ECS board. I was going to go with gigabyte, but they didn't have one with DP.

    Or does gigabyte own ecs? I'll try the Ctrl-F1 anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •